Ajuda com concatenar


#1

Amigos estou precisando de uma luz aqui :smile:
Eu tenho a seguinte planilha:

Essa planilha, é uma venda por vendedor / produto.
Nessa imagem por exemplo temos o RCA(vendedor) - código 46, e abaixo dele os itens que ele vendeu.
Quando acabam os itens que ele vendeu começa a lista do vendedor 55.

Onde eu pintei de vermelho, antigamente tinha o código do vendedor, então eu conseguia concatenar o código do vendedor com o código do item.

Concatenando a coluna AB com C - ficando por exemplo 468710 / 468700 / 468702
Assim eu conseguia puxar as informações e preencher minha matriz.

Só que agora, está dessa forma que coloquei a imagem, o código do vendedor está na parte de cima.
Tem algum modo de concatenar o código do vendedor (um numero fixo) com o código do produto do jeito que está agora, e quando terminar um vendedor, começar concatenar com outro automaticamente?

Preciso puxar a informação da coluna “L”

Espero que tenha conseguido explicar.

Desde já obrigado.


#2

Tem como postar essa planilha ai?


#3

@Serges, dê uma olhada em referências relativas e absolutas. Isso resolve seu problema. Aqui fala bastante sobre esse assunto: http://bit.ly/excel-2016-intermediario


#4

@xlarruda
Usuários novos não podem enviar anexos. :disappointed_relieved:
Não consigo postar.

Você tem algum e-mail que eu possa te enviar?

@xavier
Até conheço referências relativas e absolutas, mas não consegui achar um jeito de encaixar ela nessa planilha.

O meu problema maior, é que essa foto que postei, não tem um “padrão”.
Tipo, tem vendedor que vendeu 1 produto, vendedor que vendeu a linha toda, então eu não sei quando vai mudar de vendedor.
01 vendedor tem 01 linha abaixo dele apenas, e já muda para o próximo, tem vendedor que tem 10 linhas. E tem um total de 40 vendedores.


#5

@Serges, Bom Dia.

Manda por nuvem ou pelo meu e-mail deciog@gmail.com

Decio


#6

Enviei para seu e-mail.

Obrigado pela atenção. :grinning:


#7

@Serges< Bom Dia.

Confere se desta forma esta coreto

Se minha resposta foi útil, clique no coração é uma forma de agradecimento da ajuda

Decio
Planilha Decio 2.xlsx (98,0 KB)


#8

Formula perfeita, era exatamente o que eu estava precisando.

E eu achava que sabia alguma coisa de excel :rofl::rofl::rofl:
Preciso aprender muito ainda.

Já te agradeci no e-mail, mas faço aqui novamente.
Muito obrigado, você salvou minha vida :smile::smile:

Obrigado a todos também que gastaram um pouco de seu tempo respondendo esse tópico.

Abraço!!


#9

@Serges

Segue formula corrigida para coluna AB

Hoje esta calmo então deu par analisar melhor, fica mais rápido

=SEERRO(SE(D1<>“RCA :”;SE(D2=“RCA :”;E2;AB1);AB1);AB1)

Decio