Ajuda - cont.se


#1

Bom dia.

Estou elaborando uma planilha onde preciso usar a formula CONT.SE

Só que preciso que ela não conte referencias repetidas, como fazer?

Por exemplo.

Coluna A
João
João
Maria
Maria
Maria
Jose
Joaquim

E não quero que ela conte o João 2x e a Maria 3x, quero que conte apenas 1 para cada. Ou seja, o resultado deveria ser 4. Como fazer?


#2

Supondo que seus dados estão entre “A2” e “A8”

=SOMA(1/CONT.SE($A$2:$A$8;$A$2:$A$8))

Por se tratar de uma fórmula matricial, ao invés de apertar ENTER para finalizá-la, você deverá apertar: Crlt + Shift + ENTER (se apertar apenas enter, ela vai dar erro)

Logo ela ficará dentro de chaves assim:
{=SOMA(1/CONT.SE($A$2:$A$8;$A$2:$A$8))}

Obs* Não pode haver células vazias no intervalo por conta da divisão

Abrç!


#3

Boa tarde.

Calculo deu errado, converteu em um valor de 0,024. Mas valeu.

Alguém sabe outra forma?


#4

Deu errado pq, provavelmente você não finalizou ela com Crlt+Shift+Enter

Dá uma olhada nesse exemplo com a fórmula funcionando que eu montei pra você.

Vlw

Abrç!Conta exclusivos.xlsx (8,2 KB)


#5

No meu Excel ele fica com o { } e não calcula corretamente. =/


#6

Isso é estranho… mas o meu exemplo deu certo ou ficou com erro também?

@KelvinJustino, vou tentar pesquisar porque isso está acontecendo. Se eu encontrar alguma novidade posto aqui pra você…


#7

O seu fica certo.

Eu to achando que o erro do meu é pq tenho condições especificas nele e puxa de outra aba o resultado.


#8

@KelvinJustino . Posta ai a sua planilha, derrepente acho uma solução pra ela…


#9

A planilha real eu não posso mandar devido a informações confidenciais. Mas, segue um exemplo simples.

Exemplo.xlsx (8,7 KB)


#10

Mesmo com CTRL+SHIFT+ENTER não consigo.

Exemplo.xlsx (8,8 KB)


#11

@KelvinJustino fiz aqui e funcionou corretamente…

veja ai

Bem não sei o que pode estar acontecendo… Faça o seguinte:

Copie a minha formula e cole na sua (de cara não vai dar certo)
Aí voce altera manualmente os intervalos (os dois intervalos tem que ser os mesmos)
depois finaliza com crlt+shift+enter

e veja se dá certo. Se não der terá que econtrar outra forma de fazer isso.

Se eu achar alguma novidade te falo…

Abrç!Exemplo.xlsx (8,9 KB)


#12

É que na sua formula você dividiu Nomes Totais e Estados Totais.
Eu preciso de Nomes por Estado. Ou Seja, quantas x determinado nome aparece em determinado estado.

Por isso não deu certo, vou procurar outra maneira, valeu.


#13

Alguém com alguma alternativa? Passei a manhã inteira quebrando a cabeça e não consigo fazer. kkk


#14

Consegui fazer a mesma conta que você através de

=SOMARPRODUTO( (D4:D551<>"") / CONT.SE(D4:D551;D4:D551&"") )

Porém, ainda não consigo adicionar uma nova condição.


#15

Cara acho que eu tenho a solução do seu problema:

Tema abordado em : http://www.planilhando.com.br/forum/viewtopic.php?f=20&t=26490

06_11_17_Contar unicos com critério-Patropi.xlsx (9,6 KB)


#16

Bom dia!
Usa o excel somente o basico, quero tirar uma dúvida: **A FORMULA É MATRICIAL, PORTANTO USE CTRl+SHIFT+ENTER ** - Quando usar essa combinação e porque ???


#17

@OnlyCar, Bom dia!

Cara, se eu te disser que domino esse assunto estarei mentindo.

Mas talvez esse artigo possa te ajudar a entender melhor esse assunto…

https://gurudoexcel.com/introducao-a-formulas-matriciais/

Após terminar de ler atentamente o post, já vai conseguir até montar a sua primeira fórmula matricial… Depois é ir se aprimorando…

AH É bom que você entenda um pouco o conceito de matriz:

Abrç!


#18

Mano, era isso mesmo. Não entendi como faz, mas é isso ae.
kkkkkkkkkkkkk

Valeu mesmo! Já vai ajudar bastante.

Vou ter que achar uma forma agora de não contar um determinado valor apenas.

Mas, muito obrigado!