Ajuda Formula Excel


#1

Como resolver este caso …Como somar as saidas dos produtos imageimage


#2

Olá, @Marymeida. Tudo bem?

Você pode utilizar a função SOMASE para isso. Por exemplo:

=SOMASE(C:C;A2;E:E)


#3

@Marymeida Para entendimento, na saída de produtos (Célula B2) você quer ver o valor ou a quantidade de produtos?
Se for a quantidade de produtos, a fórmula CONT.SE() em B2 pode resolver da seguinte forma:

=CONT.SE($C$2:$C$14;$A2)

Já no caso de precisar a soma dos valores D2:D14, em relação às quantidades informadas em E2:E14. Aí se trata de uma soma e multiplicação de todos os valores, dentro de uma matriz de dados.

Para resolver isto, existem algumas alternativas (Função matricial ou Criando uma coluna de multiplicação em F2 até F14

OU, a forma que eu utilizo nesses casos e recomendo, usando a função SOMARPRODUTO(), ficando da seguinte forma, em B2, colando a fórmula até B14:

=SOMARPRODUTO($D$2:$D$14;$E$2:$E$14;--($C$2:$C$14=$A2))


#4

Obrigada pela ajuda @xavier


#5

@Wesckley Obrigada pela ajuda…