Ajuda na função SE


#1

Boa noite, estou montando uma planilha e não consigo encontrar o erro.
tenho a função Se na coluna P e estou fazendo outra função SE na coluna Q… porem quando digito SE(P8=15;“2,5”) o resultado e falso e teria que ser 2,5… como corrijo?

ou não podemos utilizar a função deste modo?


#2

CLEITON, visualmente sua logica está correta, porém pode ser uma questão de formatação. se quiser me enviar a planilha dou uma olhada para você. meu e-mail: william.aedu@gmail.com

VEJA ANEXO.


#3

recomendo a você criar mais parâmetros para a função SE, ao invés de ficar em apenas 1, ta certo que esse e seu objetivo, mais tenta mostrar algo a mais caso na célula não seja =15.


#4

Boa noite Edu tudo bem? enviei no seu e-mail para verificação, desde já agradeço pela sua ajuda.


#5

Boa noite Willian tudo bem? para ser sincero eu não sou conhecedor nato do excel rsrs por isto trabalhei com esta formula… tem outra forma ou função para esta questão?


#6

CLEITON, analisando sua logica está correta, o problema que está ocorrendo e que ele não esta encontrado o valor de 15 e por isso retorna FALSO que nesse caso e o ultimo teste logico realizado, ele percorreu toda a estrutura e não encontrou nenhum dos parâmetros passado e como o ultimo e FALSO por isso que está colocando essa palavra, se você colocar ; e 0 como parâmetro FALSO ele vai retorna 0. Faz um teste coloca 15 na P8 manual só pra você ver como ele retorna 2,5.


#7

ERRO SE.xlsx (23,1 KB)

O erro persiste William rsrs, estou enviando em anexo a planilha para facilidade em nosso caso.
verifique que mesmo mudando a mesma não corresponde.

teria que puxar no Q8 2,5 assim que P8 aparecer 15
tanto quanto puxar 100 no Q8 assim que aparecer 125 no P8.

você conhece outra função que eu possa utilizar?


#8

Olá Cleiton,
Cleiton o erro está na sua definição. Você definiu na coluna P que os valores seriam textos, ou seja, os valores estão entre aspas, portanto estão definidos como texto.

=SE(O8>100;“125”;SE(O8>80;“100”;SE(O8>70;“80”;SE(O8>60;“70”;SE(O8>50;“60”;SE(O8>35;“50”;SE(O8>
25;“35”;SE(O8>20;“25”;SE(O8>8;“20”;SE(O8>0;“15”;""))))))))))

Você deve tirar as aspas da linha acima, ai vai funcionar:

=SE(O8>100;125;SE(O8>80;100;SE(O8>70;80;SE(O8>60;70;SE(O8>50;60;SE(O8>35;50;SE(O8>25;35;SE(O8>20;25;SE(O8>8;20;SE(O8>0;15;“NÃO ENCONTRADO”))))))))))

E PARA SUMIR O FALSO, coloque igual acima no ultimo se, ou conforme abaixo

SE(O8>0;15;"" ou o não encontrado como acima, que não deve ocorrer.

Você deve tirar as aspas da coluna Q também, assim as células ficam numéricas.

Célula P8 ficaria assim:
=SE(O8>100;125;SE(O8>80;100;SE(O8>70;80;SE(O8>60;70;SE(O8>50;60;SE(O8>35;50;SE(O8>25;35;SE(O8>20;25;SE(O8>8;20;SE(O8>0;15;""))))))))))

e célula Q8 assim:
=SE(P8=125;120;SE(P8=100;95;SE(P8=80;70;SE(P8=70;50;SE(P8=60;35;SE(P8=50;25;SE(P8=40;16;SE(P8=35;10;SE(P8=25;6;SE(P8=20;4;SE(P8=15;2,5;"")))))))))))

depois arraste para as demais.

abs


#9

Boa noite.

Muito obrigado, esto mesmo.

Retiramos todas as “” ou adicionamos “” nos dois termos.

Parabéns e muito obrigado.

Resolvido.


#10

Olá Cleiton,

Não, tem que tirar, pois vc está trabalhando com números. Veja o que acontece quando vc usa as aspas. Fiz a coluna A como texto e não números e faço a comparação com aspas (textos).

abs

image


#11

bem avaliado, passou em branco na minha analise