Arredondamento para "9,99"


#1

Galera, boa noite,
Gostaria que vocês me ajudassem, pois estou tentando arredondar para cima, mas que conste o final “9,99”.
Por exemplo, o meu resultado foi igual a 213,40, eu arredondaria para 219,99,
Pois na empresa que eu trabalho, todos os valores terminam com “9,99”, sendo assim eu estou tentando fazer uma planilha que me informe o valor de venda dos produtos, já arredondando para cima com os “9,99”


#2

Boa Noite Victor!
Supondo que o Valor esteja em C1 ou Subistitua, coloque esta formula na célula que pretende o resultado.
=SE((MOD(C1;10)<>0);(ARREDONDAR.PARA.CIMA((C1/10);0))*10;A1)-0,01
Veja se e isto que quer.


#3

Victor Use esta formula te mandei erra
=SE((MOD(C1;10)<>0);(ARREDONDAR.PARA.CIMA((C1/10);0))*10;C1)-0,01


#5

SPP, Bom dia, deu “quase” certo, pois ele está arredondando para 9,99 sim,
mas quando o valor dá 220,00 por exemplo, ele está arredondando para baixo, ele arredonda para 219,99,
O correto seria arredondar para 229,99
Como posso corrigir isso?
Obrigado desde já.
Victor


#6

Vitor,Bom Dia.

Conforme formula feita pelo colega SPP
Usa desta forma, confere se deu certo para voce

=SE((MOD(C1;10)<>0);((ARREDONDAR.PARA.CIMA((C1/10);0))*10)-0,01;((ARREDONDAR.PARA.CIMA((C1/10);0))*10)+9,99)

Decio


#7

Vitor Boa tarde!
Use desta forma:

=SE((MOD(C1;9,9999999)<>0);(ARREDONDAR.PARA.CIMA((C1/9,9999999);0))*9,9999999;C1)-0,01


#8

Obrigado pela atenção Decio.


#9

Obrigado pela atenção SPP