Calcular porcentagem de presenças e faltas

Boa tarde!
Estou desenvolvendo uma planilha para escola onde trabalho e senti muitas dificuldades para adicionar uma fórmula que viesse a calcular o percentual de presenças e faltas de alunos durante o período mensal que transcorre as aulas.
Estou utilizando a seguinte fórmulas para calcular o percentual de presenças:
=SE(D57=“0%”;“0,0%”;SE(D54>=1;(100%-D57);“0,0%”))
E para o percentual de faltas:
=((D56*100%)/$AB$53/100)
Mas percebi que estas fórmulas não retorna valores exatos, ou seja, quando o número de presenças e faltas são iguais, deveria retornar um percental de 50% para ambos os casos, mas não é isso que acontece.
Peço aos caros colegas que me ajudem a solucionar este problema, e tornar esta planilha funcional sem erros.percentagem

Boa tarde…

coloque estas linhas nos percentuais.

=TEXTO(SE(D54<>0;D54/(D54+D56);0);“0,0%”)

e

=TEXTO(SE(D56<>0;D56/(D54+D56);0);“0,0%”)

Estas resolvem o seu problema.
abs

Boa tarde!
Muito obrigado!!
Funcionou perfeitamente.

1 Curtida