Cálculo de horas no excel


#1

Olá gostaria de uma ajuda!!!
criei uma planilha banco de horas ficou bem bacana mais tem uma limitação.

nas horas noturnas eu tenho um problema para somar essas horas.
EX: funcionário começa trabalhar 22:00 descansa 23:00 volta 00:00 sai 05:00 da manhã.
nesse caso da erro ao calcular quantas horas ele trabalhou.

Como posso fazer isso, já que a jornada de trabalho se inicia em um dia mais termina me outro.
aguardo as sugestões.

forte abraço a todos.


#2

Veja se é isso:

Calculo de horas.xlsx (8,3 KB)


#3

Olá Francysco,
Esta abaixo não tem problema do descanso ser antes ou depois das 24 horas:

=SE(A2>B2;“24:00”-A2+B2+D2-C2; SE(C2>D2;B2-A2+“24:00”-C2+D2; D2-C2+B2-A2))

Pode ser que você tenha que formatar esta célula para horas.

abs


#4

Muito show não tinha tido essa criatividade parabéns!!!
fórun showww.


#5

obrigado!!! parabéns !


#6

Bom dia, estava fora… por isso não comentei antes…
Valeu Francysco…
abs


#7

Boa tarde!
Pessoal,
Estou com um problema parecido para calcular horas no Excel. Só que no meu caso é somente inicio e fim de turno e está dando negativo, já mudei algumas configurações como ativar 1904 mas aí da 18:00 e eu preciso do resultado de 6:00 trabalhadas.
Exemplo:
Inicio saída Horas trabalhadas
20:00 02:00 6:00
Preciso que me de o resultado assim.
Poderiam me ajudar nesse calculo.


#8

Boa noite Jeferson (@jef).

A formula é quase a mesma

=SE(B4<A4 ; “24:00:00” - A4 + B4 ; B4 - A4)

image

Abs


#9

Uê eu fiz isso mas não deu certo, deve ser pq eu não coloquei “24:00:00” e sim “24:00”. Mas joia vou mudar aqui muito, obrigado iporto.


#10

Olá @JEF
Duas coisas:
1 - Se vc não colocar as aspas não vai funcionar: “24:00:00”
2 - Tem que formatar a celula da formula como hora, assim:

image

abs


#11

Ok! Obrigado mais uma vez Iporto.