Calculo entre datas sobre valor fixo e proporcional


#1

Boa tarde pessoal,

Procurei nos tópicos mais não encontrei algo que pudesse me ajudar.

Estou com a seguente dúvida, tenho um valor X"A2" que cobro pra determinados clientes na seguinte situação, se iniciar “C4” alguma atividade no período do dia 1 até dia 15, o valor é integral, mas se o inicio do contrato for já no dia 16 até 28, 30 ou 31 dependendo do mês o valor é proporcional da data que iniciou até o fechamento no ultimo dia do mês “D4”, o valor de cobrança aparecerá em “F4”.

Pessoal já tentei função SE de várias formas, mas ainda não tive exito na formulação, preciso muito dessa formula.


#2

Oi @Brayanluca. Tudo bem?

Se entendi bem o seu caso, você pode resolvê-lo utilizando a seguinte função:

=SE(C4=0;0;SE(DIA(C4)<=15;$A$2;$A$2/DIA(FIMMÊS(A4;0))*$A$2))

Espero ter ajudado.

Abraços.


#3

Caro @Brayanluca eu preciso de duas informações para fazer a fórmula que você precisa:

1- O maior valor a ser cobrado ao cliente depois que passa do dia 15.: Ex: Início do contrato dia 16 de um mês que vai até o dia 31?

2- O menor valor a ser cobrado ao cliente depois que passa o dia 15.: Ex: Início do contrato no último dia do mês?

Com esse dois valores limites eu consigo criar uma fórmula que distribua o valor no restante dos dias.

Aguardo a sua resposta!


#4

Caro @Brayanluca,

Ainda aguardando sua resposta!

Obrigado!


#5

Boa tarde meu querido,

Acho que minha explicação não ficou tão clara para você;

A minha questão é a seguinte, o valor fixado no contrato é de R$75,00 e não passará disso, pois o valor só tende a decair, na seguinte ideia, que se iniciar um contrato do dia 1 do mês até dia 15 do mesmo mês o valor não subirá e decairá, será sempre R$75,00, é um valor fechado conforme a negociação e estabelecido em contrato, mas em contra partida em sequencia do dia 16 até o final do mês, podendo ser dia 28,30 ou 31 será proporcional;

Cálculo proporcional de dias de contrato, pela análise de dias contados em um mês que contenha 31 dias:
Se entender que a dizima para a cobrança de um dia de contrato seria de (R$75,00 /31 dias = R$2,42) R$2,42 nessa analogia a cobrança para o contrato do dia;
16 até dia 31 (15 dias) R$ 36,30
19 até dia 31 (12 dias) R$ 29,04
25 até dia 31 (06 dias) R$ 14,52
29 até dia 31 (02 dias) R$ 4,84

O valor da cobrança só mudará após o dia 16 que entrará em proporcional conforme explicação acima, do dia 1 de todos os meses até o dia 15 será o valor integral de R$75,00, não sei se ficou claro minha explicação, mas espero que sim!!!


#6

Boa tarde Xavier,

Obrigado pela sua ajuda!

Sua fórmula foi muito útil, tendo em vista que somente troquei o final, pois ele multiplicava a dizima pelo valor do contrato e assim o valor aumentava e o que eu realizei foi multiplicar essa dizima pelos dias de contratos efetivos, conforme abaixo;

=SE(C4=0;0;SE(DIA(C4)<=15;$A$2;$A$2/DIA(FIMMÊS($A$5;0))*E4))

Me trouxe o que eu precisava, Obrigado pela ajuda de vocês todos!

Resultado Final


#7

Boa tarde @Brayanluca. Fico contente em ter podido ajudar.

Acho que ainda mais valioso que o resultado da solução, é o aprendizado que fica pro uso eterno.

Abraços.


#8

Boa @xavier!

Essa função FIMMÊS(), não conhecia…vivendo e apreNdendo…minha fórmula ficou bem maior por desconhecê-la.

=SE(C4="";"";SE(DIA(C4)<16;$A$2;($A$2/2)-(($A$2/2)/(D4-DATA(ANO(C4);MÊS(C4);15))*(C4-DATA(ANO(C4);MÊS(C4);15)))))

Mas está valendo e o importante é que o @Brayanluca teve seu problema solucionado!

Parabéns!


#9

Claro, @exceldiretoaoponto!

Eu aprendo coisas novas quase todos os dias. O mais legal é que quanto mais aprendo, mas vejo que ainda não estou nem perto de ser o “sabichão” do Excel. É incrível. E estes fórum é um lugar onde podemos compartilhar muito amor e conhecimento.

Vejo que você também é muito ativo por aqui. Eu já estou nesse fórum há alguns anos (desde a plataforma antiga) e é incrível o quanto já aprendi por aqui também.

Seja bem vindo, e, independente de quais sejam os interesses, vamos todos crescer juntos com liberdade por aqui.

Podemos trocar figurinhas também.

Abraços.


#10

Obrigado pela força que vocês me deram…

Fico muito bom o resultado!