Cardápio de alunos

Gostaria de uma ajuda em uma planilha, tipo assim quando coloca-se 1,200 kg de bolacha, na coluna ao lado converte-se para embalagens no caso 3 pacotes (0,400 g), e se passar de 20 pacotes q converta em caixas ( uma caixa tem 20 pacotes de 0,400g - caixa tem 8 kgs).
São vários itens:
Almondegas: lata 0,420 g caixa com 24 latas
Açúcar e arroz: 1 kg fardo com 30 ks
Achocolatado: 0,200 g caixa com 24 pacotes.
Me ajudem por favor…

Bom dia Edvaldo,

Veja se te ajuda.
coloque
…A-------------B----- C---- D ------- E
1 PRODUTO - QTD. - PCT - Caixas - Resultado
2 bolacha - 1200 - 400 - 20 - =SE(B2/C2>=D2;B2/D2&" Caixas";B2/C2&" Pacotes")

E quando passar de 20 pacotes (1cx), Exemplo 50 pacotes ( 2 vcs + 10 ) ou 110 pacotes ou mais ?

Olá,

Neste caso, vai querer que exiba como? 2 caixas e 10 pacotes?