Como somar células entre intervalos


#1

Tenho uma planilha e gostaria de somar apenas valores que estão a cada 16 linhas, por exemplo, somei a linha j17, 16 linhas depois é a j33(soma), adiciona mais 16 e é a J49(soma), assim por diante, como faço isso?

​​​​​​​ps: versão do excel é 2016.


#2

Olá, @celobittar. Tudo bem?

Não existe uma forma automática de fazer esse tipo de procedimento, você precisa criar esta automação. Uma forma que pendei é escrever, em coluna auxiliar, os endereços de células que se deseja somar. Por exemplo, escrever o número 16 em alguma células qualquer, por exemplo, A1 e escrever na coluna ao lado:

=A1+17

Na célula A2, escrever:

=A1+18

Daí é só arrastar as duas colunas para as funções seguirem nas demais células.

Na coluna ao lado, neste caso, C, você escreve os endereços:

="J"&A1&":J"&B1

Arrastando a função também para baixo. Agora você já pode usar a soma referenciando estas auxiliares utilizando a função INDIRETO:

=SOMA(INDIRETO(C1))

Aí é só arrastar também.

Dá pra ter outras ideias de como fazer isso, como, por exemplo, utilizando a função DESLOC, mas acho que é mais complicado de entender.