Comparação de data e hora e informação de SLA


#1

Pessoal preciso de uma ajuda.

Preciso de uma formula onde mostre todos chamados que eu tenho com SLA vencido e o calculo de quanto tempo vencido.

Exemplo:

Data de abertura do chamado: 11/10/2018 09:20:22
Data de fechamento do chamado: 11/10/2018 10:20:22
= RESULTADO : 01:00:00 / SLA NÃO VENCIDO

Preciso comparar as duas datas com horarios e em outra coluna colocar se esta vencido ou não.

Me passaram essa formula, porem não entendi muito bem e não sei se essa esta correta
=SE(TEXTO(A3;“hh:mm:ss”)<=TEXTO(A4;“hh:mm:ss”);“CERTO”;“ERRADO”)


#2

=SE(A4<A3;"";SE(A4>A3;A4-A3))
Em formato use este
[h]:mm:ss


#3

Use esta esqueci o sinal de igual
=SE(A4<=A3;"";SE(A4>A3;A4-A3))


#4

EXEMPLO2


#5

Esse é um exemplo de como eu precisava ‘-’


#6

Mario não entendi seu exemplo,mas acho que tem uma tolerância de uma hora, e isto


#7

Mario veja se isto te ajudaExemplo Mario.xlsx (10,7 KB)


#8

Obrigado gênio :slight_smile:
Problema resolvido,
Desculpe a ignorância, estou começando agora …

Vlw, abcs


#9

Como eu faço esse calculo de horas.
1 exemplo.

no caso que eu mencionei que o mesmo venceria se ultrapasse 2 horas.

e se fosse.
1 hora
1 e 30 etc…

por que eu terei que mudar em alguns casos…


#10

Mario bom que te ajudou.
No próximo tópico tenha calma que quase tudo a solução, concentre em um tópico de cada vez.


#11

Uma duvida, como eu faço para alterar o tempo de SLA?


#12

Uma possibilidade seria trabalhar com o formato de horas na fórmula por exmplo:

Ao invés de trabalhar com horas assim: 0,0416666666666667

poderia ser assim tbm:

=SE(C1="";"";SE(D1="";"";SE(D1<=VALOR(“01:00:00”);“NÃO VENCIDA”;“VENCIDA”)))

Aí é só mudar a hora entre aspas para o horário que quiser


#13

Nossa.
Muito mais facil.
Show!
Muito obrigado a vcs.


#14

Coloque em uma célula o tempo que pretende, vá em formatar escolha geral, aparecera o valor desejado.
qualquer duvida me mande o tempo que pretende.


#15

deu erro


#16

As vezes dá um problema com as aspas se você copiar e colar daqui do fórum.
Apague as aspas e as insira novamente pelo seu teclado.

ou copie novamente daqui de baixo:

=SE(C1="";"";SE(D1="";"";SE(D1<=VALOR("01:00:00");"NÃO VENCIDA";"VENCIDA")))


#17

Verdade, vcs são nota10.

Ultima duvida, ultima coisa :slight_smile:
nessa mesma planilha, irei adicionar uma coluna informando os números de chamado e outra coluna informando a prioridade.

Tenho 4 prioridades diferentes.
1-Crítica - SLA 6 horas
2-Alta - SLA 8 horas
3-Média - SLA 10 horas
4-Normal - SLA 12 horas


cada prioridade tem 1 tempo diferente de SLA…

Alguma ideia de como posso fazer?


#18


Essa seria minha planilha de dados original que daria seguimento a uma dinâmica.


#19

Você quer mudar a prioridade manualmente e , automaticamente, altere o tempo?

ou quer alterar o tempo manualmente e, automaticamente, altere a prioridade?


#20

Na extração de dados que eu faço, ele já vem com todas informações exceto Tempo de Vida e SLA.
A Coluna prioridade já vem com a extração que eu faço diariamente…

No caso quando eu jogasse os dados na planilha, eu queria que o mesmo identificasse essas prioridades e SLA e que me retornasse o TEMPO DE VIDA e SLA.