CONT.SE em matriz, soma do resultado de cada linha


#1

Olá, colegas! Me ajudem se puderem! Gostaria de reunir em uma única fórmula os resultados das duas fórmulas que estão descritas na imagem abaixo. O objetivo é, em uma fórmula/célula única, contar quantas células com valor >0 estão atribuídas ao “Vendedor_1” na matriz. Obs: a coluna “produto” não influencia no meu objetivo. Obrigado!


#2

@adm.recife, acho que a única maneira de fazer isto é criando uma função matricial.

{=SE($C$3:$C$9="Vendedor 1";CONT.SE($E$3:$I$9;">0"))}

Neste caso, é preciso pressionar “Ctrl + Shift + Enter” ao terminar de digitar a fórmula para que funcione.

Se você estiver querendo fazer o que eu imagino que deseja, então pode escrever desta forma:

{=SE($C$3:$C$9=C3;CONT.SE($E$3:$I$9;">0"))}


#3

Você pode usar o soma.se tambem.
18


#4

O resultado daria 33.