Contagem de vencimento por hora


#1

Boa tarde galerinha

Vou tentar explicar da melhor forma possível o que to tentando fazer.

Tenho uma planilha que consta nas célula “X” a data com hora “16/01/2019 10:15” personalizado como “dd/mm/aaaa hh:mm” eu tenho que cumprir uma tarefa até 6 horas após a inclusão dessa data e horário, porém não seria tão complicado se o cálculo fosse direto. Essa contagem tem que ser entre as 8:00h até as 18:00h do mesmo dia. Exemplo: se a inclusão for 16/01/2019 10:15 eu tenho que cumprir essa tarefa até as 16/01/2019 16:15, mas se ela entrar em 16/01/2019 as 16:15 eu tenho que desconsiderar o tempo que não tem atividade (horário de trabalho) das 18:01 até as 7:59 do dia seguinte, ou seja, o tempo contará das 16:15 até as 18:00 que seria 1:45h e reinicia a contagem as 8:00h do dia seguinte me restando 4:15h terminando o prazo então as 17/01/2019 12:15h.

Espero que eu tenha explicado de uma forma que possam entender e que possam me ajudar.

Agradecido.

Cleber


#2

Comentado só pra não te deixar aqui sem resposta, mas ainda não imagino como fazer esse cálculo.


#3

Deu certo sem usar VBA. rsrs
=SE(A3+6/24>(INT(A3)+18/24);(INT(A3)+1+8/24+(A3+6/24-(INT(A3)+18/24)));A3+6/24)

Substitua A3 pela célula que contém sua hora e funcionará.
Fiz o seguinte: se a soma da hora do pedido + 6 horas for superior a 18:00 do mesmo dia, a fórmula pega o saldo restante e soma às 08:00 do dia seguinte.
Se o pedido for feito no sábado tem que colocar outro SE. :wink:
LIKE NA RESPOSTA!


#4

Boa tarde.

Vou tentar essa fórmula amigo… Obrigado por enquanto…


#5

Bom dia Valteson.

Funcionou muito bem, e realmente tenho abre aos sábados é outro horarios de funcionamento. Das 8:00 as 14:00. To tentando aqui, mas se tiver alguma ideia, ficarei grato.

Obrigado


#6

Bom dia.

Como eu faço para que o excel reconheça que é sábado e possa diferenciar o horario já que os imputs serão das 8:00h as 14:00?

Grato.


#7

Tem uma função no excel que é DIA.DA.SEMANA(). Ela retorna o dia da semana em números. Você pode usar:
=se(DIA.DA.SEMANA(A1) = 6; <condição de sábado>;<condição dos dias da semana>)


#8

Bom dia, Valterson

Não estou conseguindo trabalhar no meu excel porque está em ingles kkkkk

Você pode me ajudar?

você já me deu a formula

=SE(A3+6/24>(INT(A3)+18/24);(INT(A3)+1+8/24+(A3+6/24-(INT(A3)+18/24)));A3+6/24)

O que eu preciso agora é que, se o resultado da soma das horas cair no sábado que se some + 48h e o horario de sabado muda para das 8:00 as 14:00h ai terá que somar 34h.

Grato.


#9

Desculpa não ter olhado. Estou sem tempo esses dias.