Contar grupos relacionado a outros grupos


#1

Bom dia,

Gostaria de solucionar um problema, para facilitar coloquei uma imagem
image

Preciso saber uma formula que de o resultado correto de quantos pedidos estão entregue, no prazo, atrasado e cancelado.

Encontrei uma formula que da o total dos grupos =SOMARPRODUTO(1/CONT.SE(Tabela1[Pedido];Tabela1[Pedido]))

Porém necessito de uma que conte o status por grupo por ex o resultado de “Prazo” seria 2. pois são 2 pedidos que tem o mesmo status.

Alguem poderia me ajudar! Ficarei muito feliz em solucionar esse problema!.

Atenciosamente
Alvaro França


#2

Encontrei mais uma formula que fa o total de grupos, mas preciso saber quantos grupos estão Atrasado, No Prazo etc…
=SOMA(SE(FREQÜÊNCIA(SE(NÚM.CARACT(Tabela1[status])>0;CORRESP(Tabela1[status];Tabela1[status];0);""); SE(NÚM.CARACT(Tabela1[status])>0;CORRESP(Tabela1[status];Tabela1[status];0);""))>0;1))

OBS: essa Formula tem que apertar Ctrl+Shift+Enter para funcionar


#3

Segue minha contribuição:

Cole em H1 finalizando com Ctrl + Shift + Enter:

=SOMARPRODUTO(SEERRO(1/CONT.SES($A$2:$A$100;$A$2:$A$100;$B$2:$B$100;$G1);0))

depois arraste a fórmula para as células de baixo.


#4

Muito obrigado! Se precisar estou a disposição!