Contar o numero de vezes que um valor é repetido


#1

contase_nomes_separados_virgula.xlsx (9,3 KB)

Galera, a formula =CONT.SE(A2:A10; “Carlos”) ela me retorna o valor total de vezes que o nome “Carlos” é repetido em um coluna, mas caso o mesmo esteja dividindo a célula com outro nome separado por virgula o retorno fica zerado, como faço para resolver?.


#2

Boas @thailan,

confirma se com esta fórmula resolve o teu problema.

=+CONTAR.SE(H6:H8;" * “&“carlos”&” * ")


#3

Apenas uma observação:

Em Português(Br) essa fórmula continua como: CONT.SE

Não copie e cole pois não dará certo. Digite-a . Abrç!


#4

cont_nomes_separados_virgula.xlsx (10,0 KB)

Galera eu tentei as duas formas e não funcionou:

@xlarruda o valor retorno 0
@Galamba o valor retorno #nome?


#5

@thailan,

corrigir a formula e está a funcionar.

Retorna 7 Carlos, é o valor esperado?

cont_nomes_separados_virgula.xlsx (10,0 KB)


#6

Sim!! Perfeitamente!! Muito obrigado.


#7

Caso queira contar o nome “Carlos” duas vezes como ocorre na célula A12 então use essa fórmula:

=SOMA(NÚM.CARACT(A2:A12)-NÚM.CARACT(SUBSTITUIR(A2:A12;D2;"")))/NÚM.CARACT(D2) + SOMA(NÚM.CARACT(A2:A12)-NÚM.CARACT(SUBSTITUIR(A2:A12;MINÚSCULA(D2);"")))/NÚM.CARACT(MINÚSCULA(D2))

Obs. Finalize-a com Crtl + shift + Enter

Nesse caso o resultado seria 8.

Abrç!


#8

Cara, muito bom mesmo !! obrigado


#9

Pessoal!

Caso eu queira saber quantas vezes o nome Carlos aparece com Andre? É só mudar &/* pelo nome desejado?


#10

Na minha fórmula seria:

No lugar de “Carlos” você colocaria “Carlos,André”. Mas isso limita muito a fórmula e poderia dar muito erro de cálulo uma vez que ele só contaria se fosse exatamente nessa ordem e diferenciaria maiusculas de minúsculas.

Ps. Eu não recomendo.

mas vou ver o que posso fazer…


#11

Tenta desta forma

=+CONTAR.SE(A:A;""&“carlos”&"")+CONTAR.SE(A:A;""&“andre”&"")

se o resultado esperado for 11 está a funcionar.

cont_nomes_separados_virgula.xlsx (10,0 KB)


#12

@xlarruda beleza irmão. Obrigado, mas caso eu não consiga encontrar outro jeito vou utilizar essa forma.
@Galamba na verdade seria 5vezes, segue novo exemplo.

separando_por_equipe.xlsx (9,7 KB)


#13

@thailan,

tens razão, eu não li correctamente o que pretendias.

Queres o Carlos e Andre juntos e não a soma deles todos.

Desculpa.


#14

Tem alguma sugestão @Galamba, de como puxar a soma da dupla?


#15

@thailan, veja se isso resolve:

cont_nomes_separados_virgula.xlsx (10,0 KB)


#16

Essa formula você tinha até sugerido… ficou perfeito irmão, muito obrigado pela ajuda.