Contar valores com condicional

Boa tarde!
Desenvolvi uma planilha que registra a participação do aluno, cujo mesmo é avaliado mediante a atribuição de conceitos. De acordo com a participação do aluno nas aulas é retornado um percentual de frequencia e média mensal.
Mas eu queria usar uma função ou fórmula, que quando não houver aula num determinado dia não seja alterado o percentual de presença do aluno, bem como a média mensal do mesmo.
Para apresentar o percentual de presenças nas aulas, utilizei a seguinte função:
=SEERRO(G17/CONT.VALORES(I17:BD17);"")
E a média mensal:
=SOMA(I17:BD17)/$AB$53
Queria poder resolver este erro, ou seja, quando naquele determinado dia não acontecer aula, o professor atribuir o conceito “SAT”, SEM ATIVIDADES. E assim não alterar o percentual de frequencia e média mensal.