Copiar todos os valores da linha baseados em uma célula

Olá queridos,
Preciso transferir os valores de uma linha inteira baseado em uma valor, porém tem varias linhas com a mesma correspondências que precisam ser copiadas e com procv não estou conseguindo,
Vou colocar a tabela que fia mais fácil de visualizar.

Pontos de análise CH4 CO2 O2
C1 76.60 20.00 0.20
C3 77.70 20.30 0.00
A1 77.70 20.30 0.20
A1 78.20 17.70 0.20
C1 76.30 20.10 0.20
B2 77.50 20.00 0.20
C1 76.60 20.00 0.20
B1 77.70 20.30 0.00

Nesse caso, vou criar outra tabela idêntica e quero buscar apenas os valores das linhas que contém C1 como ponto de análise, por exemplo.

Agradeço a ajuda.

@Marildo, Bom Dia.

Seja bem vindo

Poste um modelo com resultado esperado se não conseguir poste em site como SendSpace/Mega/GoogleDrive/Dropbox Drive outros

Decio

@deciog, bom dia.
Muito obrigado.

A planilha é bastante grande, então fiz um recorte para exemplificar.

Abraços

@Marildo, Bom Dia.

Confere se é desta forma que desejas

Se minha resposta foi útil, clique no coração é uma forma de agradecimento da ajuda

Decio
Pasta1 Decio.xlsx (13,6,KB)

1 Curtida

Olá Decio,
Funcionou perfeitamente.
Estou “digerindo” a sua formula.
Fiquei com uma duvida, estou replicando em outra planilha que tem uma coluna a mais
que esse exemplo que te passei. Nesse ultima coluna a formula não funciona. Tenho que mexer em algum parâmetro?

Muito obrigado pela ajuda.

@Marildo, Bom Dia.

As formula estão presa par cinco coluna mas pode ser aumentada olha exemplo

Nesta formula você tem que aumentar as colunas

=SEERRO(SE(CONT.SE(L$5:L5;L5) < COLS($E$5:$I$5); L5; ÍNDICE(DESLOC($E$5:$I$5;;-1;;1); CORRESP(L5;DESLOC($E$5:$I$5;;-1;;1); 0)+1)); “”)

Exemplo para mais uma coluna olhar negritos

=SEERRO(SE(CONT.SE(L$5:L5;L5) < COLS($E$5:$J$5); L5; ÍNDICE(DESLOC($E$5:$J$5;;-1;;1); CORRESP(L5;DESLOC($E$5:$J$5;;-1;;1); 0)+1)); “”)

Nesta também tem que aumentar

=SEERRO(ÍNDICE($E$5:$I$18;MENOR(SE(ÉNÚM(LIN($D$5:$D$18)-LIN($A$2)-2/($D$5:$D$18=$L5));LIN($D$5:$D$18)-4);LIN(A1));CORRESP(M$4;$E$4:$I$4;0));"")

Exemplo para mais uma coluna olhar negritos

=SEERRO(ÍNDICE($E$5:$j$18;MENOR(SE(ÉNÚM(LIN($D$5:$D$18)-LIN($A$2)-2/($D$5:$D$18=$L5));LIN($D$5:$D$18)-4);LIN(A1));CORRESP(M$4;$E$4:$j$4;0));"")

Se minha resposta foi útil, clique no coração é uma forma de agradecimento da ajuda

Decio

1 Curtida

Olá Decio,
muito obrigado, sua ajuda foi muito útil.
Abraços