Corresponder último valor de uma coluna com último valor de outra

Olá.
Como posso corresponder último valor de uma coluna, neste caso seria uma DATA mas os valores são iguais, com último valor de outra coluna?

Finalidade: Fazer um gráfico com esses 2 valores.

Ficheiro Excel de Teste
FE1.xlsx (10,6,KB)

@viriato74, Bom Dia.

Confere se é desta forma que desejas

Se minha resposta foi útil, clique no coração é uma forma de agradecimento da ajuda

Decio
FE1 Decio.xlsx (11,5,KB)

1 Curtida

Não tem como aparecer o último valor de cada dia?

Dia 01/01/2020 50€
Dia 01/01/2020 50€
Dia 01/01/2020 40€

Resultado Dia 01/01/2020 40€


Dia 02/01/2020 50€
Dia 02/01/2020 50€
Dia 02/01/2020 35€

Resultado Dia 02/01/2020 35€


Dia 03/01/2020 50€
Dia 03/01/2020 40€
Dia 03/01/2020 10€

Resultado Dia 03/01/2020 10€

Obrigado

@viriato74

Poste um modelo com a situação que a formula tem que ser feita, também coloca onde quer o resultado

Decio

Sempre que forem inseridos novos dados a função fazer automaticamente o cálculo. Ir buscar o último valor de cada dia à coluna C e o último valor de cada dia da coluna J.

Modelo: FE1 Decio.xlsx (12,4,KB)

Ir buscar o último valor de cada dia à coluna C e o último valor de cada dia da coluna J.

@viriato74, Bom Dia.

Confere se é desta forma que desejas

Se minha resposta foi útil, clique no coração é uma forma de agradecimento da ajuda

Decio
FE1 Decio 2.xlsx (13,1,KB)

1 Curtida

Perfeito, não consegui chegar lá.
Obrigado pela ajuda.

=SE.ERRO(AGREGAR(15;6;SE(FREQUÊNCIA((C$3:C$17<>"")*C$3:C$17;$C$3:C$17);C$3:C$17;"");LIN(A1));"")

Qual o significado de 15;6?

Penso que o 15 seja o número de células mas não sei o significado do 6.

Já percebi.