CRIAR FÓRMULA PARA ELABORAÇÃO DE PLANILHA DE DADOS


#1

Prezados amigos, gostaria de solicitar a ajuda de vocês para a solução deste meu problema.

Sou estudante de doutorado e estou trabalhando com uma planilha enorme de dados (de A1 a V9204). Eu necessito reduzir estes dados para que eu possa interpretá-los.

Portanto, eu gostaria da ajuda para saber qual fórmula utilizar para criar uma planilha que faça uma busca nesta planinha original dos dados (de A1 a V9204) e extraia as informações para esta nova planilha que irá conter a fórmula.

O que eu preciso é o seguinte:
Nesta nova planilha eu teria uma célula para INSERIR o código do SUJEITO (ex. AD01) e outra célula para INSERIR a HORA (ex. 13:00) que desejo.
A partir daí, e fórmula busca na planilha original (de A1 a V9204) os dados referentes a estes dois parâmetros e realizar uma MÉDIA com os valores encontrados a partir de uma variavel (Var.) de uma determinada coluna.

Abaixo eu vou colocar os Links para uma Planilha “Modelo_Original” (a qual é parecida com a planilha original, mas reduzida em 3 pacientes) e outro para uma outra Planilha “Modelo_Final_Resultado” (a qual conterá os resultados).

Na planilha original dos dados (de A1 a V9204), os dados do código do SUJEITO estão na Coluna A1 até A9204 e os dados da HORA estão na Coluna C1 até C9204. E o cálculo da MÉDIA dos valores encontrados para o SUJEITO na HORA DETERMINADA serão das Variáveis contidas a partir da Coluna F até a Coluna V.

Link para Planilha "Modelo_Original"

https://app.box.com/s/0yz5qorjjiq78olk9uoc817qm3e8fk5b

Link para Planilha " Modelo_Final_Resultado"

https://app.box.com/s/1bsk64tk9uexj60iwipiugtziyoar7rc

Desde já agradeço a ajuda de vocês.

Abraços


#2

@BrunoM, creio que a função MÉDIASES seja a função correta para o seu caso.

=SEERRO(MÉDIASES([Modelo_Original.xlsx]Planilha1!F$2:F$330;[Modelo_Original.xlsx]Planilha1!$A$2:$A$330;$A2;[Modelo_Original.xlsx]Planilha1!$C$2:$C$330;$B2);0)

Nestes caso é sempre melhor trabalhar em uma só pasta (arquivo). Se trabalhar em pastas separadas não for um requisito, recomendo fortemente colocar ambas na mesma pasta de trabalho do Excel.


#3

Obrigado pelo envio da planilha com a fórmula.

Contudo, eu continuo tendo um problema e gostaria de saber se poderia me ajudar.

Vc fez a planilha com base no modelo que enviei contendo dados de somente 3 pacientes. Sendo assim, eu estava tentando expandir tanto a Planilha “Base de Dados” quanto a Planilha 1 com os resultados, para que eu possa fazer com todos os dados que tenho. E ao fazer isso, e colar todos os dados originais, os cálculos não são efetivados. Pois o objetivo é criar uma planilha para ser dinâmica, adequando a qualquer base de dados de tamanhos variados.

Atualmente a base dados original vai de A1 a V9204, sendo que a linha 1 é cabeçalho.

Desde já agradeço a ajuda.


#4

@BrunoM, creio que basta atualizar as referências:

=SEERRO(MÉDIASES([Modelo_Original.xlsx]Planilha1!F:F;[Modelo_Original.xlsx]Planilha1!$A:$A;$A2;[Modelo_Original.xlsx]Planilha1!$C:$C;$B2);0)

#5

Modelo_Original.xlsm (80,1 KB)

Seria isso: Fiz uma macro que gera os dados, calcula a media, e salva a planilha na pasta padrao (Meus Documentos)

Nao se esqueca de sempre ATUALIZAR A LISTA do SUBJECT e HORA.

A planilha deve comportar ate 10000 linhas preenchidas.