Data por Extenso


#1

Boa tarde! como escrever uma data por extenso e concatenar a cidade e estado.
Exemplo: 17/05/2018 - Castro - PR, 17 de Maio de 2018.


#2

Seria isso?

Data_completa.xlsm (8,6 KB)


#3

Funcionou, mas não preciso da quinta feira, pode me explicar o que representa [$-F800] ??


#4

Pra falar a verdade também não sei dizer. Vou pesquisar depois. Mas se for em formatação personalizada verá que ele aparece. (foi de lá que me baseei).

Segue fórmula e anexo corrigidos:

=A2 & ", " & TEXTO(B2;"dd") & " de " & TEXTO(B2;"mmmm") & " de " & TEXTO(B2;"aaaa")

Data_completa.xlsm (8,6 KB)


#5

Pelo que pesquisei um pouco, este código hexadecimal indica em que língua o formato deve ser retornado, mas realmente não encontrei muito conteúdo sobre o assunto

[$-F800] = Português
[$-409] = Inglês
[$-804] = Chinês


#6

A formula pode ser somente assim

=TEXTO(B2; “[$-F800]”)

resultado fica

quinta-feira, 17 de maio de 2018

Pode usar também em formatação de célula personalizada somente [$-F800] tem o mesmo resultado é ótimo

Decio