Descobrir números diferentes

Boa noite,
Estou com um problema, tenho duas listas de mais de 500 linhas, onde consta números de 9 dígitos, em planilhas diferentes, com frequência preciso verificar os da lista 1 que não constam na lista 2.

Alguma sugestão de como fazer usando uma função?

Pode usar um cont.se.

1 Curtida

@decio, Bom Dia.

Oi chara o ideal é postar um modelo e se possível qual é a versão do Excel, mostro para varias versões confere

Usando Office 365 usa desta forma

Esta formula mostrar o que tem na coluna C e não tem coluna B
=FILTRO($C$4:$C$16;ÉERROS(CORRESPX($C$4:$C$16;$B$4:$B$16)))

Esta formula mostrar o que tem na coluna B e não tem coluna C
=FILTRO($B$4:$B$16;ÉERROS(CORRESPX($B$4:$B$16;$C$4:$C$16)))

Caso queira mostrar sem repetição todos da coluna B e C usa desta forma
=CLASSIFICAR(ÚNICO(SE(SEQUÊNCIA(2LINS($B$4:$C$16))<=LINS($B$4:$C$16);$B$4:$B$16;ÍNDICE($C$4:$C$16;SEQUÊNCIA(2LINS($B$4:$C$16))-LINS($B$4:$C$16)))))

Para outras versões

Tem na coluna A e não tem na coluna B
=SEERRO(ÍNDICE($A$2:$A$6;MENOR(SE(ÉERROS(CORRESP($A$2:$A$6;$B$2:$B$6;0));LIN($A$2:$A$6)-LIN($A$2)+1);LIN(A1)));"")

Ou tem na coluna B e não tem na coluna A
=SEERRO(ÍNDICE($B$2:$B$6;MENOR(SE(ÉERROS(CORRESP($B$2:$B$6;$A$2:$A$6;0));LIN($B$2:$B$6)-LIN($B$2)+1);LIN(A1)));"")

Se minha resposta foi útil, clique no coração é uma forma de agradecimento da ajuda

Decio

1 Curtida

Bom dia ,
Obrigado xará, excelente resolveu meu problema.
Um abraço

Bom dia Valteson,
Obrigado camarada, também foi possível utilizar para resolver o problema.
Um abraço.