Dúvida contar datas com diferença menor x dias


#1

Boa noite. Por favor como faço para contar quantas datas de um mesmo registro possuem diferença menor que 7 dias? Ex:

Cód cliente. Data

  1.               28/06/2018
    
  2.                01/07/2018
    
  3.                 10/07/2018
    
  4.                  03/07/2018
    
  5.                   05/07/2018
    
  6.                   07/07/2018
    

No registro 45 contaria 1 data
No registro 01 contaria 1 data
Totalizando 2 datas

Obrigada


#2

Bom dia @Alun

Entre a “linha” 1 e 6, 1 e 5 não conta ?
Seria apenas entre 1 e 2, 2 e 3, 3 e 4, 4 e 5, 5 e 6 ?
Entre a linha 1 e as 2,3,4,5,6 não conta ?

É que vc colocou registro 45 e registro 01… Não entendi…

Mas acredito que seja isto que vc queira. Não coloque esta formula na ultima linha, pois a proxima linha vai estar em branco e vai contar como verdadeira.

image

se for entre 1 e 2, 2 e 3, 3 e 4, 4 e 5, 5 e 6, a formula seria esta.

=SE(C14-C13>=7;1;SE(C14-C13<=-7;1;""))
que pode ser substituida por esta
=SE(abs(C14-C13)>=7;1;"")

abs


#3

Boa noite Lporto por me responder.

É que os nr que podem ser código de clientes, podem não vir sequenciais. E se entre 3 datas de um mesmo cliente somente uma delas tem o intervalo menor que 7 dias ( a comparação é feita sempre em relação a primeira data do cliente) conto só uma.

Veja se agora expliquei melhor por favor, mas fique à vontade para tirar todas as dúvidas.

A sua fórmula acredito que está certa, só falta a parte de contar sempre em relação a primeira data.

Muito obrigada mais uma vez pela sua ajuda.

Abs.


#4

Boa tarde Liége.
Ah, agora é outra fórmula…

Não sei o quanto vc entende de excel, ok, então vou explicar uma linha e vc replica para onde for usar.

=SE(ABS($C$13-C14)>=7;1;"")
Fixei a célula C13 assim $c$13. Então se for colocar isto na F15, fixando-a, faça $F$15
Tirei a próxima, que seria a C14, ai vc replica até a linha 18 e a C13 ficará sempre como C13, as demais mudam automaticamente. Não coloque a formula na D13, pois ela é a “cabeça” dos cálculos, então comece a formula na D14.
Espero ter ajudado, mas qualquer coisa é só escrever.
Abs

image


#5

Boa noite Luiz. Obrigada, vc me ajudou muito. Conte comigo se precisar. Abs.