Duvida - Corresp


#1

Bom dia.

Mais 1 duvida para conta. kkk

Quando eu uso a formula CORRESP em uma determinada coluna, EX: A1:A5

Se a linha célula A3 estiver vazia ele retorna com #N/D. Como faço para isso não ocorrer? Para o Excel simplesmente não considerar no calculo?

@Edit
Adicionado planilha exemplo.

PLANILHA - EXEMPLO.xls (43,5 KB)

Att.

Kelvin Justino


#2

Oi @KelvinJustino,

Tudo bom? Uma estratégia muito utilizada para isso é usar SEERRO ou ÉERRO na fórmula. Explicamos com detalhes neste post: https://blog.luz.vc/excel/esconda-erros-de-formulas-excel-com-funcao-eerros-e-seerro-c/

Abraços!


#3

Boa tarde.

Não posso usar SEERRO, porque não é um erro. Se usar o SEERRO ele me converte em um resultado pré-estabelecido e incorreto.

De qualquer forma, consegui resolver o problema com uma matricial.

Obrigado.


#4

Quem tiver com a mesma duvida, usei:

=SOMA(–(FREQÜÊNCIA(SE(Sheet1!A$4:A$1000&""=Indicadores!A3;CORRESP(Sheet1!D$4:D$1000;Sheet1!D$4:D$1000;0));LIN(INDIRETO(“1:”&LINS(Sheet1!D$4:D$1000))))>0))