Duvida em como colocar a hora e a data automática


#1

Boa tarde
Meu nome é Julio Felipe
Estou fazendo uma planilha online para vários vendedores e gostaria de saber como eu posso fazer para automatizar a hora e a data de cada campo.
Exemplo:
Quando o vendendo preencher o campo B6 eu quero que o campo B2 me diga automaticamente o horário e a data que isso ocorreu

Fiz o seguinte usei a função =SE(ÉCÉL.VAZIA(B6);"";AGORA())
ao fazer isso de certo forma acaba funcionando pq traz a hora q foi preenchido o campo mas so que nao funciona pq ele atualiza a hora em todos os campos q forem sendo editados queria saber se tem como colocar um stop ou fazer com q ele so funcione para a celular q ele foi criado q no caso do exemplo foi B6
Obrigado e fico enciosamente a espera


#2

Olá colega @Juliofelipe, acredito que apenas fórmulas não resolvam.

Fiz uma solução alternativa via UDF. Veja se te atende.

Abrç!

Data e Hora fixo.xls (71 KB)


#3

VBA funciona para planilhas online?


#4

Pois é. Esse é um problema.
Excel online é limitado nesse sentido…


#5

Juliofelipe, Bom Dia.

Eu uso teclas veja como

Se é para colocar data uso CTRL+;
Se é para colocar hora uso CTRL+:

ou uso macete em formulas

Tenho uma planilha onde coloco desta forma na Célula G9

=SE(J9="";AGORA();G9)

Dará erro de formula sicular mas funciona perfeitamente, na célula J9 eu tenho valor então quando tem valor não muda, entende.

Se minha resposta foi útil, clique no coração é uma forma de agradecimento da ajuda


#6

Muito interessante essa lógica colega @deciog Acredito que poucas pessoas sabem essa forma.
Tentei uma forma de inverter através da sua lógica mas sem solução.
por exemplo, alterar a data quando houver valor na celula.

Mas mesmo assim já aprendi mais um alternativa! Vlw.


#7

xlarruda, Bom Dia.

Obrigado pelo feedback

Isso eu não vi em lugar algum eu bolei quando precisei

na sua duvida usa desta forma aqui deu certo

=SE(J10<>"";AGORA();G10)

Decio


#8

Colega @deciog obrigado pela sua resposta.
Nesse caso a hora fixa se o valor da celula J10 estiver vazio. Interessante… abre muitas possibilidades.
Muito bom mesmo. Parabéns


#9

Colegas, se ainda quiserem, podem remover a mensagem de referencias circular conforme ensina o artigo abaixo:

E eu ainda adicionaria uma formatação condicional para que a data e hora só ficasse visivel quando a condição de travamento da data fosse ativado.

Teste Fixar Hora.xlsx (13,6 KB)

Procurava uma resposta pra isso a muito tempo.
Solução genial colega @deciog parabéns novamente !
Abrç!

Colega @Valteson, como no seu caso está ultilizando Excel online, acredito que apenas a fórmula do colga @deciog já te atenda bem.

Obs. Não sei como o Excel online trata as referencias circulares…


#10

xlarruda

excelente gostei

também estou aprendendo

Decio


#11

Meu deus, o Décio faz o Excel dar certo até dando erro.

Muito bom esse truque! Obrigado por compartilhar amigo.


#12

@Yure, Bom Dia.

Obrigado pelo feedback, demorei porque estava viajando

Abraços

Decio


#13

muito obrigado deu certo sim