Dúvida Fórmula SE contendo texto e cálculo [Resolvido]


#1

Olá pessoal, estou tendo um grande problema em uma fórmula de Excel, segue abaixo o link para verificarem a planilha:

Percebi que o erro ocorre porque a fórmula utiliza as colunas “G” e “H” que contém texto, se na coluna “I” tivesse como alterar a fórmula ou fazer que o excel identifique que se aparecer a palavra “EXCLUÍDA” é igual a “0” zero daria certo, pois quando coloco algum valor nas colunas “G” e “H” a fórmula funciona.

Fórmulas utilizadas:
Coluna G:
=SE(OU(E3=“NÃO”;C3=0);“EXCLUÍDA”;300)

Coluna H:
=SE(G3=“EXCLUÍDA”;“EXCLUÍDA”;G3*C3)

Coluna I:
=SE(D3=“ARROZ”;(SE(B3<=2;H3*(0,375/100F3);SE(B3>2;H3(0,3475/100F3)))))
+SE(D3=“FEIJAO”;(SE(B3<=2;H3
(0,375/100F3);SE(B3>2;H3(0,3475/100F3)))))
+SE(D3=“PEIXE”;(H3
(0,44/100F3)))
+SE(D3=“CARNE”;(H3
(0,44/100F3)))
+SE(D3=“FRANGO”;(H3
(0,44/100F3)))
+SE(D3=“LATICINIOS”;(H3
(0,44/100F3)))
+SE(D3=“ENLATADOS”;(H3
(1,25/100F3)))
+SE(D3=“DEMAIS PRODUTOS”;(H3
(1,25/100*F3)))

Alguém pode me ajudar por favor?

Agradeço desde já.


#2

Fala, @David_Benner. Tudo bem?

Segue sua planilha ajustada:
duvida_formula_excel.xlsx (10,1 KB)


#3

Xavier, muitíssimo obrigado, era isso mesmo que precisava, valeu irmão!!


#4

Uma outra forma de fazer é usar formatação personalizada confere

Decio
duvida_formula_excel Decio.xlsx (11,1 KB)


#5

Obrigado Decio!! :blush: