Duvida na formula SE


#1

Boa Tarde.
Criei essa formular SE, porém estou com problema que quando digito valores de horas acima de 18:00hr a formula não lê. Não sei o que ta acontecendo. E uma formula para que quando eu digitar qualquer por exemplo 06:25 ou 08:20 ela entra num criterio conforme voces vão ver na formular. Porém quando digitar a hora acima de 18 a formular não lê. Podem me ajudar? A formula que fiz e essa:
=SE(D25>=‘TABELA DE CÓDIGOS’!A2;SE(D25<=‘TABELA DE CÓDIGOS’!A122;“06:00 AS 08:00”;SE(D25>=‘TABELA DE CÓDIGOS’!A123;SE(D25<=‘TABELA DE CÓDIGOS’!A242;“08:00 AS 10:00”;SE(D25>=‘TABELA DE CÓDIGOS’!A243;SE(D25<=‘TABELA DE CÓDIGOS’!A362;“10:00 AS 12:00”;SE(D25>=‘TABELA DE CÓDIGOS’!A363;SE(D25<=‘TABELA DE CÓDIGOS’!A482;“12:00 AS 14:00”;SE(D25>=‘TABELA DE CÓDIGOS’!A483;SE(D25<=‘TABELA DE CÓDIGOS’!A602;“14:00 AS 16:00”;SE(D25>=‘TABELA DE CÓDIGOS’!A603;SE(‘TABELA DE CÓDIGOS’!A722;“16:00 AS 18:00”;SE(D25>=‘TABELA DE CÓDIGOS’!A723;SE(D25<=‘TABELA DE CÓDIGOS’!A842;“18:00 AS 20:00”;SE(D25>=‘TABELA DE CÓDIGOS’!A843;SE(D25<=‘TABELA DE CÓDIGOS’!A962;“20:00 AS 22:00”;SE(D25>=‘TABELA DE CÓDIGOS’!A963;SE(D25<=‘TABELA DE CÓDIGOS’!A1082;“22:00 AS 00:00”;SE(D25>=‘TABELA DE CÓDIGOS’!A1083;SE(D25<=‘TABELA DE CÓDIGOS’!A1202;“00:00 AS 02:00”;SE(D25>=‘TABELA DE CÓDIGOS’!A1203;SE(D25<=‘TABELA DE CÓDIGOS’!A1322;“02:00 AS 04:00”;SE(D25>=‘TABELA DE CÓDIGOS’!A1323;SE(D25<=‘TABELA DE CÓDIGOS’!A2;“04:00 AS 06:00”))))))))))))))))))))))))


#2

Thiago,

Depois vou tentar ver uma solução, mas antes, por favor, dê uma olhada no seguinte comando:

SE(‘TABELA DE CÓDIGOS’!A722;

Acho que sua intenção era colocar:

SE(D25<=‘TABELA DE CÓDIGOS’!A722;

Veja que no seu está faltando: D25<=

Abraço.


#3

Boa Tarde meu Amigo.

Acho que a formular vai embolando a cabeça da gente e acaba perdendo alguma coisa que tinha q colocar. Acertei esse detalhe e ai funcionou.
Agora tive outro problema que quando digito 22:01 a formula ta dando falso. Ja revisei tudo mais não consegui achar o erro. Poderia ajudar?