Duvida SOMASE em varias ABAS


#1

Bom dia,

tenho duvida na formula somase, tenho uma planilha de controle de paciente são 25 abas e no final tem uma aba de TOTAL , nessa aba de total quero fazer uma formula de somase mais não está funcinando me ajudem

fomula: =SOMASE(‘1:25’!B5:B100;B5;‘1:25’!E5:E100)


#2

O correto é usar a formula INDIRETO, para que posso montar a formula corretamente poste um modelo

Decio


#3

está falando que sou usuário novo não consigo anexar voce tem algum email que posso te enviar?


#4

Ok eu acho um erro do fórum pois duvidas sempre é bom mandar um modelo,

Então segue meu e-mail para mandar um modelo deciog@gmail.com

Decio


#5

Bom dia.
Este não é o melhor modo, mas acho que é isto que você quer:
=SOMASE(‘1’!$B$5:$b$100;B5;$E$5:$E$100)+SOMASE(‘2’!$B$5:$b$100;B5;$E$5:$E$100)+SOMASE(‘3’!$B$5:$b$100;B5;$E$5:$E$100)+SOMASE(‘4’!$B$5:$b$100;B5;$E$5:$E$100)+SOMASE(‘5’!$B$5:$b$100;B5;$E$5:$E$100)+SOMASE(‘6’!$B$5:$b$100;B5;$E$5:$E$100)+SOMASE(‘7’!$B$5:$b$100;B5;$E$5:$E$100)+SOMASE(‘8’!$B$5:$b$100;B5;$E$5:$E$100)+SOMASE(‘9’!$B$5:$b$100;B5;$E$5:$E$100)+SOMASE(‘10’!$B$5:$b$100;B5;$E$5:$E$100)+SOMASE(‘11’!$B$5:$b$100;B5;$E$5:$E$100)+SOMASE(‘12’!$B$5:$b$100;B5;$E$5:$E$100)+SOMASE(‘13’!$B$5:$b$100;B5;$E$5:$E$100)+SOMASE(‘14’!$B$5:$b$100;B5;$E$5:$E$100)+SOMASE(‘15’!$B$5:$b$100;B5;$E$5:$E$100)+SOMASE(‘16’!$B$5:$b$100;B5;$E$5:$E$100)+SOMASE(‘17’!$B$5:$b$100;B5;$E$5:$E$100)+SOMASE(‘18’!$B$5:$b$100;B5;$E$5:$E$100)+SOMASE(‘19’!$B$5:$b$100;B5;$E$5:$E$100)+SOMASE(‘20’!$B$5:$b$100;B5;$E$5:$E$100)+SOMASE(‘21’!$B$5:$b$100;B5;$E$5:$E$100)+SOMASE(‘22’!$B$5:$b$100;B5;$E$5:$E$100)+SOMASE(‘23’!$B$5:$b$100;B5;$E$5:$E$100)+SOMASE(‘24’!$B$5:$b$100;B5;$E$5:$E$100)+SOMASE(‘25’!$B$5:$b$100;B5;$E$5:$E$100)
coloque esta formula na planilha total.
Com um botão na planilha total dava para reduzir muito.
abs


#6

Resultado na A1 da planilha Total:

   Sub Soma()
    for i = 1 to 25
    soma = worksheetfunction.sumif(sheets(i).range("B5:B100","B5","E5:E100"))
Sheets("planilhatotal").range("A1").value = Sheets("planilhatotal").range("A1").value + soma
    Next i
    End Sub

#7

Perfeito @xlarruda