Erro de formula


#1

SE(VALOR(EXT.TEXTO(A6;LOCALIZAR(",";A6;1)+1;1))<=5;ARREDONDAR.PARA.BAIXO(A6;0);A6);SE(VALOR(EXT.TEXTO(A6;LOCALIZAR(",";A6;1)+1;1))>5;arreARREDONDAR.PARA.CIMA(A6;0);A6)

10,0
valor nuloi


#2

Bom dia Paulo!
Favor descrever o que desejas fazer com a fórmula, para que possamos te ajudar melhor com a mesma, ou até obter uma solução mais simplificada.

Pelo que entendi, você está tentando definir um valor exato de arredondamento com base no número seguinte após a vírgula, mas quando coloca um valor exato a fórmula não o reconhece.

Utilizando a função SEERRO e corrigindo o erro de digitação na fórmula, acho que funcionará perfeitamente para você!

=SEERRO((SE(VALOR((EXT.TEXTO(A6;LOCALIZAR(",";A6;1)+1;1)))<=5;ARREDONDAR.PARA.BAIXO(A6;0);ARREDONDAR.PARA.CIMA(A6;0)));A6)


#3

SEERRO((SE(VALOR((EXT.TEXTO(A6;LOCALIZAR(",";A6;1)+1;1)))<=5;ARREDONDAR.PARA.BAIXO(A6;0);ARREDONDAR.PARA.CIMA(A6;0)));A6)
se eu coloco a6=1,5 arredonda para 1
se eu coloco a6= 5 dar um #valor!
Porque qual a causa


#4

Bom dia Paulo!
Testei a fórmula e aqui funcionou como está, a leitura da fórmula nos dá as seguintes premissas, que significam o comportamento esperado da fórmula:

  • Caso o número após a vírgula seja menor ou igual a 5, arredonde para baixo;
  • Caso o número após a vírgula seja maior do que 5, arredonde para cima;
  • Se as hipóteses não forem satisfeitas, a função SEERRO indica o Excel para informar o valor da célula. Que seria para o caso de números como o 5 que você tinha dito.

Estamos utilizando a função SEERRO, porque o Excel não reconhece o que está após a vírgula para números redondos, por isso, quando você digita 10,0 3,0 ou 5 sua fórmula não o reconhece e você recebe a mensagem de #VALOR!.

A fórmula seguinte está funcionando corretamente aqui:

SEERRO((SE(VALOR((EXT.TEXTO(A6;LOCALIZAR(",";A6;1)+1;1)))<=5;ARREDONDAR.PARA.BAIXO(A6;0);ARREDONDAR.PARA.CIMA(A6;0)));A6)


#5

Exemplo 28.7 quero adicionar 0.1 para torna a case decimal par como eu fasso


#6

@Paulosales

Coloca alguns valores e o resultado espera, assim fica mais fácil montar a formula

Existe farias forma de arrendondar preços, só precisamos saber a regra para isso, poste vários exemplos com resultados ok

Decio


#7

Quero aredondar 22,5 para 22
24,5 para 24
23,5 para 24
25,5 para 26


#8

Quero aredondar 22,5 para 22
24,5 para 24
23,5 para 24
25,5 para 26
SEERRO((SE(VALOR((EXT.TEXTO(A6;LOCALIZAR(",";A6;1)+1;1)))<=5;ARREDONDAR.PARA.BAIXO(A6;0);ARREDONDAR.PARA.CIMA(A6;0)));A6)


#9

@Paulosales, Bom Dia.

Você coloca 23,5 para 24 e 25,5 para 26, é preciso saber qual condição que é arredondado para cima, pois não vejo a regra para isso

Qual a regra

Decio