Escolha de um intervalo para média


#1

Boa tarde,
Preciso de uma formula que faça uma média.
Tenho dois intervalo contendo quase sempre os mesmo produtos. Preciso de uma formula que me traga a média de um dos intervalos obedecendo o criterio: se a media do intervalo 01 for igual a Zero, quero que me retorne a média do produto do intervalo 02.
Vou postar o exemplo.Problema.xlsx (8,8 KB)


#2

Cole essa fórmula em E15, depois arraste-a para baixo:

=SEERRO(SEERRO(SE(MÉDIASE($B$3:$B$11;"="&D15;$C$3:$C$11)=0;MÉDIASE($F$3:$F$11;"="&D15;$G$3:$G$11);MÉDIASE($B$3:$B$11;"="&D15;$C$3:$C$11));MÉDIASE($F$3:$F$11;"="&D15;$G$3:$G$11));“Sem dados”)


#3

vou testar aqui e te falo. Obrigado por enquanto!


#4

Perfeito @xlarruda. Cara essa formula ficou muito Fo…a. Parabéns cara. Me ajudou demais essa formula.