Estou com uma duvida sobre formulas

Olá

Estou com uma duvida e gostaria de saber se pode ser resolvida

Queria saber se existe alguma formula que consiga copiar um intervalo de células desconsiderando os zeros como mostra a imagem nesse link:

Desde já agradeço

@3333hugo, Bom Dia.

Seja bem vindo

Conforme sua imagem usa desta forma

=SEERRO(ÍNDICE($B$4:$B$32;MENOR(SE($B$4:$B$32>0;LIN($B$4:$B$32)-3);LIN($A1));1);"")

NOTA:. As aspa neste fórum é diferente das aspas para uso do Excel quando você fizer
CTRL+C e depois CTRL+V muda as aspas para funcionar.

Confere se é desta forma que desejas

Se minha resposta foi útil, clique no coração é uma forma de agradecimento da ajuda

Decio