Formula do PROCV

Boa tarde!
Prezados, estou há dias perdido em uma fórmula que não consigo resolver

nas células de coluna H:H aceitam apenas valores exatos, gostaria de incluir valores diferentes

deixei anexo no drive pois nao consigo incluir
https://drive.google.com/file/d/1nf2Y59zqgbNDAXCNfNKbvF9eE3hDpN7W/view?usp=sharing

Se eu colocar 6 no valor da H4, gostaria que me entregasse o mesmo valor que o 8
e assim vai indo
se colocar 9 e 10 o mesmo valor …

Se alguém souber qualquer ideia pra alterar a fórmula, fico grato, pq to há dias nisso mesmo

@renaneemm, Bom Dia.

usa esta formula

=SEERRO(ÍNDICE($D$3:$D$81;MENOR(SE($G$4&$H$4&$I$4=$A$3:$A$81&$B$3:$B$81&$C$3:$C$81;LIN($D$3:$D$81)-2);1));$D$3)

Confere se é desta forma que desejas

Se minha resposta foi útil, clique no coração é uma forma de agradecimento da ajuda

Decio

1 Curtida

Boa tarde!

Prezado, te agradeço demais pelo auxílio, porém quando insiro o valor não exato ele sempre me retorna o “40”
Como na imagem:

apenas esse retorno do erro que não consigo resolver =/

@renaneemm, Bom Dia.

Primeiramente voce não clicou coração curtindo a ajuda dada

Voce escreveu ((gostaria que me entregasse o mesmo valor que o 8
e assim vai indo se colocar 9 e 10 o mesmo valor …)), então fixei o valor 40

O que deve aparece se o valor não for exato?

Decio

1 Curtida

Boa tarde!

Prezado, peço desculpas por deixar de curtir e pela incontextualidade.
Seria ele buscar o valor no intervalo anterior. Por exemplo:

DN—UHC—COMPR MÁX—DN VENT.

100—43------299---------------------100
100—140-----8------------------------50

Se eu digitar UHC=50 (está entre 43 e 140), ele deveria retornar DN VENT = 100 (o valor do 43)

@renaneemm, Boa Tarde

Vejo amanha pois hoje muito suporte cliente pedindo varias alterações

Obrigado
Decio

1 Curtida

@renaneemm, Bom Dia.

Acredito que só por Macro pois não consegui encontrar um jeito de dar a resposta, desculpas.

Decio