Fórmula em Excel - Contar e parar se encontrar o n° 1


#1

Boa tarde,
Eu preciso de uma fórmula para Excel que conte as células de uma linha até encontrar o número 1 e então pare,
retornando a quantidade de células até o valor especificado.

Alguém ai sabe como fazer?

Grato.


#2

@ombrerico, Acredito que somente é possível programando. Sendo assim, se tiver interesse em um desenvolvedor, mande um e-mail para exlplanilhas@gmail.com com a sua planilha e um descritivo da funcionalidade que deseja.


#3

Supondo que seu intervalo de dados seja de A1:A20:

para achar o número 1:

=SEERRO(LIN(ÍNDICE($A$1:$A$20;CORRESP(1;$A$1:$A$20;0)));“Número 1 não encontrado”)

para melhor entender a fórmula, verifique esse arquivo:

Encontrar número.xlsx (9,6 KB)


#4

ombrerico, Bom Dia.

Confere se é desta forma que deseja somar até encontrar numero 1 para e volta a contar

Decio
Exemplo Decio.xlsx (10,0 KB)


#5

tenta essa =CORRESP(1;B2:H2;0)