Formula para banco de horas


#1

Boa tarde!

Tenho a formula a baixo:
=SE(H2="";"";SE(E(H2>=“16:55:00”+0;H2<=“17:05:00”+0);“17:00”;H2))

Ela faz a seguinte leitura:

Se no H2 estiver em branco deixa branco se não e se H2 for maior que “16:55:00” e menor 17:05:00 então considera 17:00

O que eu quero acresentar e se for sabado a formula será a mesma porem com mudança de horario =SE(H2="";"";SE(E(H2>=“11:55:00”+0;H2<=“12:05:00”+0);“17:00”;H2)) pois os funcionarios so trabalham no sabado ate 12:00

Vale lembra que a coluna A ja informa o dia da semana.


#2

@ljrbrasil, Boa Tarde

O ideal é postar a planilha de exemplo, pode postar na nuvem ou drives ou programas como 4Shared outros

Para que posamos saber se é sábado ou domingo tem que ter a data, que neste seu exemplo não consta

Poste um modelo

Decio


#3

@deciog
Obrigado pela ajuda. consegui aqui uma formula que ja resolveu:

=SE(H3="";"";
SE(DIA.DA.SEMANA(C3;2)<=5;
SE( E(MOD(H3;1)>=VALOR.TEMPO(“16:55:00”);MOD(H3;1)<=VALOR.TEMPO(“17:05:00”)); INT(H3)+VALOR.TEMPO(“17:00:00”); H3);
SE( E(MOD(H3;1)>=VALOR.TEMPO(“11:55:00”);MOD(H3;1)<=VALOR.TEMPO(“12:05:00”)); INT(F3)+VALOR.TEMPO(“12:00:00”); H3)
)
)