Formula Para cálculos Envolvendo Datas


#1

Boa tarde,

Pessoal preciso de uma formula:
Ex: na coluna “A10:A100” tenho valores que variam de 100 a 500. Na célula “A1” tenho data atual (hoje()). Preciso criar uma formula na coluna “B” que faça a seguinte conta:1) se o valor que estiver em “A10” estiver entre 100 e 200 e a data atual (hoje()) estiver entre 01/out e 31/MAI quero que retorne 0,3. Mas se a data atual estiver entre 01/Jun e 30/SET, quero que retorne 0,2.
2) se o valor que estiver na célula “A10” estiver entre 201 e 300 e data atual estiver entre 01/Out e 31/Maio quero que retorne 0,5. Mas se a data atual estiver entre 01/JUN e 30/Set quero que retorne 0,4.
3) se o valor que estiver na célula “A10” estiver entre 301 e 500 e a data atual estiver entre 01/out e 31/Mai quero que retorne 0,7. Mas se a data estiver entre 01/jun e 30/set quero retorne 0,6.

Obs: para facilitar pretendo colocar essas datas na seguintes células B2= 01/out; C2= 31/Mai; D2= 01/Jun; E2= 30/Set.
A formula tem que pegar as datas dessas células para não precisar colocar a data dentro da formula.
Desde já agradeço a quem puder ajudar.


#2

Olá Vilmar. Tudo bem?

Na célula B10, cole esta fórmula: =SE(E(A10>=100;A10<=200);SE(E($A$1>=$B$2;$A$1<=$C$2);0,3;0,2);SE(E(A10>200;A10<=300);SE(E($A$1>=$B$2;$A$1<=$C$2);0,5;0,4);SE(A10>300;SE(E($A$1>=$B$2;$A$1<=$C$2);0,7;0,6))))

Depois é só arrastar para o restante das células. :grin:

Abraços.


#3

Obrigado Xavier. Deu certinho!
Obrigado mesmo.


#4

Fico feliz que tenha dado certo e que tenha ajudado. :grin: