Formula para tabela de preço com vários prazos


#1

Boa tarde, sou novo por aqui. Vamos ao caso, se puderem ajudar, agradeço muito.

Tenho uma tabela de preços com 15 itens, cada um tem seu código. Esses, podem ser vendidos com prazo de 0, 7, 14, 21, 28 e 35 dias. Para cada um desses prazos há um valor.

Quero colocar o prazo de pagamento, via validação de dados em lista. E, a partir da escolha do prazo, que a planilha fosse preenchida de forma automática em cada um de seus itens, somente uma vez.

Já tentei via SE(E, contudo como são vários prazos, teria que fazer uma formula SE(E gigantesca.

Os Senhores tem alguma saída.
Obrigado


#2

Boa tarde Ricardo.
Você pode usar o procv.
a formula para o seu esquema é a seguinte:
=SE(C3="";"";SE(C3=0;PROCV(B3;$O$3:$U$17;2;FALSO);SE(C3=7;PROCV(B3;$O$3:$U$17;3;FALSO);SE(C3=14;PROCV(B3;$O$3:$U$17;4;FALSO);SE(C3=21;PROCV(B3;$O$3:$U$17;5;FALSO);SE(C3=28;PROCV(B3;$O$3:$U$17;6;FALSO);SE(C3=35;PROCV(B3;$O$3:$U$17;7;FALSO);"")))))))

abs


#3

Muitíssimo obrigado.