Formula similar a PROCV para células preenchidas é Repetida

Olá ,

Eu tenho uma tabela(01) que exibe para min apenas os dados que necessito que são os que estão classificados como “Não pago”, o que preciso é criar uma planilha para relatório onde só vai exibir apenas aquelas células que estão preenchidas , o porém é que existem alguns dados que se repetem.

Pasta de Exemplo.xlsx

Usei um auxiliar para saber se a linha continha valores ou não. Caso positivo ele soma 1 ao valor máximo que o antecede.
E na outra planilha utilizei a formula:
=SE(LIN(A1)>MÁXIMO(Lançamento!$A$1:$A$31);"";ÍNDICE(Lançamento!C:C;CORRESP(MENOR(Lançamento!$A$1:$A$31;LIN(A1));Lançamento!$A$1:$A$31;0);1))

@pedro286, Bom Dia.

Seja bem vindo

Usei formula matricial sem coluna auxilar, nota que alterei o nome do cabeçalho classificação que estava errado

Confere se é desta forma que desejas

Se minha resposta foi útil, clique no coração é uma forma de agradecimento da ajuda

Decio
Pasta de Exemplo Decio.xlsx (16,2,KB)