Função Cont.Ses + Data


#1

Bom dia equipe.

Como faço para obter valores de uma planilha usando dois critério o mês e duas palavras chaves = Cont-se( A1:A15; “maça” “Banana”; Mês (junho));

image

@xavier
@xlarruda


#2

Supondo que as datas estão na coluna A e que as frutas estão na coluna B .

Finalize a fórmula com Ctrl + Shift + Enter:

=SOMARPRODUTO((MÊS($A$1:$A$15)=6)*($B$1:$B$15="maça")+(MÊS($A$1:$A$15)=6)*($B$1:$B$15="banana")*NÚM.CARACT(DIREITA($B$1:$B$15;1)))


#3

image

Finalizei a fórmula com Ctrl + Shift + Enter. #Valor!

exemplo.xlsx (9,1 KB)


#4

Na fórmula matricial todos os valores da coluna tem de estar OK.
Isso aconteceu porque o regitro “30/02/2018” é um texto e nao data. Para certificar disso mudei a formatação desta coluna para geral. todos os valores se tranformaram em números inteiros menos o ultimo registro.

apague esse último registro (30/02/2018) ou redigite-o e verá o resultado.

exemplo.xlsx (9,4 KB)


#5

Eu consigo utilizar a célula F2 para espefica ro mês?


#6

Nesse ultimo anexo que eu enviei sim…

Segue a fórmula alterada para usar a celula F2 como referencia:

=SOMARPRODUTO((MÊS($A$1:$A$10)=MÊS("1/"&F2))*($B$1:$B$10="maça")+(MÊS($A$1:$A$10)=MÊS("1/"&F2))*($B$1:$B$10="banana")*NÚM.CARACT(DIREITA($B$1:$B$10;1)))

exemplo.xlsx (10,0 KB)


#7

Nessa condição você valida os dois critérios: Banana e Maça

(DIREITA($B$1:$B$10;1)

Se ambas estivessem em colunas distintas, ficaria assim?

(DIREITA($B$1:$B$10;1)+(ESQUERDA($A$1:$A$10;1)

. Segue o exemplo.

image


#8

Colega @ThailanGodoy

Não é bem isso:

A função SOMARPRODUTO permite usar vários critérios ao mesmo tempo porém ela tem um problema… Ela não conta, apenas soma.

Sendo assim não tem como somar banana nem maça, pois não são número e sim texto. (não há lógica matemática nisso)

A função NÚM.CARACT(DIREITA($B$1:$B$10;1)) converte banana ou maça no número 1.
Ela está dizendo que , se contarmos apenas um caracter da direita para a esquerda em uma célula da coluna B, o total de carcteres dessa função será 1. (que é exatamente o que agente precisa para contar ao invés de somar)

Feito isso a função somar produto irá continuar somando. Porém de um em um sempre que as condições forem verdadeiras.

Logo somar de 1 em 1 da no mesmo que CONTAR.

Ex. 1 maça + 1 laranja + 1 banana . A soma é igual a 3.
1 maça + 1 laranja + 1 banana . A contagem de itens também é igual a 3.

Os critérios de fato estão aqui:

(MÊS($A$1:$A$10)=MÊS("1/"&F2))*($B$1:$B$10="maça")+(MÊS($A$1:$A$10)=MÊS("1/"&F2))*($B$1:$B$10="banana")

Repare que primeiro eu peço para ele trazer a quantidade (lembre da conversão que expliquei acima) de itens que competem ao mes em f2 e é igual maça.
Na sequencia eu peço para fazer o mesmo porém ao invés de maça, com banana.

Depois e só somar a quantidade dos dois… repare no sinal de ++* lá em cima.

Nesse caso que você sugeriu basta remover a soma e deixar apenas uma das duas frutas (a que você deseja obter o resultado)
ex.

ao invés de :
(MÊS($A$1:$A$10)=MÊS("1/"&F2))*($B$1:$B$10="maça")+(MÊS($A$1:$A$10)=MÊS("1/"&F2))*($B$1:$B$10="banana")

faça:

`(MÊS($A$1:$A$10)=MÊS(“1/”&F2))*($B$1:$B$10=“maça”) e continue a fórmula…

SEGUE ARQUIVO COM TABLEA PREENCHIDA…

exemplo.xlsx (10,4 KB)