Função de tempo


#1

Pessoal, bom dia.

Em uma célula eu tenho o horário que uma demanda foi feita em outra o turno, ao identificar o horário que foi feito qual é a formula utilizada para preencher o turno?

exemplo:

09:00 = MANHÂ
12:00 = TARDE
20:00 = NOITE

duvida.xlsx (19,8 KB)


#2

@thailan, veja se a formula te atende. Criei uma tabelinha auxiliar para que você possa definir os intervalos, tipo, de que horário, até que horário é manhã, tarde, ou noite. Coloquei valores padrões. Dê uma olhada no exemplo:

Exemplo Yure.xlsx (20,0 KB)


#3

@thailan, Bom dia.

Cole essa fórmula em B2:

=SE(E(TEXTO(A2;"hh:mm:ss")<TEXTO("6:00";"hh:mm"));"MADRUGADA";SE(E(TEXTO(A2;"hh:mm:ss")<TEXTO("13:00";"hh:mm"));"MANHÃ";SE(E(TEXTO(A2;"hh:mm:ss")<TEXTO("18:00";"hh:mm"));"TARDE";"NOITE")))


#4

@Yure

Se o campo fica em branco é preenchido como madrugada, como faço para colocar se o campo estiver vazio = vazio.


#5

Altere a fórmula de B2 para a seguinte e arraste para as células abaixo:

=SE([@[Hora da execução]]<>"";PROC([@[Hora da execução]];$G$2:$I$5);"")


#6

@Yure

Está dando erro.

Exemplo Yure.xlsx (10,5 KB)


#7

@xlarruda
Funcionou… só que se o campo HORÁRIO DE EXECUÇÃO estiver em branco ele preenche como madrugada… tem como deixar o campo embranco também?

xlarruda.xlsx (20 KB)


#8

Segue:

=SE(A2="";"";SE(E(TEXTO(A2;"hh:mm:ss")<TEXTO("6:00";"hh:mm"));"MADRUGADA";SE(E(TEXTO(A2;"hh:mm:ss")<TEXTO("13:00";"hh:mm"));"MANHÃ";SE(E(TEXTO(A2;"hh:mm:ss")<TEXTO("18:00";"hh:mm"));"TARDE";"NOITE"))))


#9

@thailan, você havia copiado a fórmula mas quando passou para a planilha ela ficou usando a matriz de procura em 2 argumentos diferentes da função PROC.

Segue o arquivo consertado, agora deve funcionar de acordo.

Exemplo Yure.xlsx (10,7 KB)


#10

@Yure
É verdade, peço desculpa e muito obrigado pelo ajuste.
Funcionou perfeitamente!!! Muito obrigado!


#11

Valeu! Caso precise de mais alguma coisa é só perguntar!


#12

@xlarruda

Muito obrigado! Funcionou!!