Função de tempo

Pessoal, bom dia.

Em uma célula eu tenho o horário que uma demanda foi feita em outra o turno, ao identificar o horário que foi feito qual é a formula utilizada para preencher o turno?

exemplo:

09:00 = MANHÂ
12:00 = TARDE
20:00 = NOITE

duvida.xlsx (19,8 KB)

@thailan, veja se a formula te atende. Criei uma tabelinha auxiliar para que você possa definir os intervalos, tipo, de que horário, até que horário é manhã, tarde, ou noite. Coloquei valores padrões. Dê uma olhada no exemplo:

Exemplo Yure.xlsx (20,0 KB)

1 Curtida

@thailan, Bom dia.

Cole essa fórmula em B2:

=SE(E(TEXTO(A2;"hh:mm:ss")<TEXTO("6:00";"hh:mm"));"MADRUGADA";SE(E(TEXTO(A2;"hh:mm:ss")<TEXTO("13:00";"hh:mm"));"MANHÃ";SE(E(TEXTO(A2;"hh:mm:ss")<TEXTO("18:00";"hh:mm"));"TARDE";"NOITE")))

1 Curtida

@Yure

Se o campo fica em branco é preenchido como madrugada, como faço para colocar se o campo estiver vazio = vazio.

Altere a fórmula de B2 para a seguinte e arraste para as células abaixo:

=SE([@[Hora da execução]]<>"";PROC([@[Hora da execução]];$G$2:$I$5);"")

1 Curtida

@Yure

Está dando erro.

Exemplo Yure.xlsx (10,5 KB)

@xlarruda
Funcionou… só que se o campo HORÁRIO DE EXECUÇÃO estiver em branco ele preenche como madrugada… tem como deixar o campo embranco também?

xlarruda.xlsx (20 KB)

Segue:

=SE(A2="";"";SE(E(TEXTO(A2;"hh:mm:ss")<TEXTO("6:00";"hh:mm"));"MADRUGADA";SE(E(TEXTO(A2;"hh:mm:ss")<TEXTO("13:00";"hh:mm"));"MANHÃ";SE(E(TEXTO(A2;"hh:mm:ss")<TEXTO("18:00";"hh:mm"));"TARDE";"NOITE"))))

2 Curtidas

@thailan, você havia copiado a fórmula mas quando passou para a planilha ela ficou usando a matriz de procura em 2 argumentos diferentes da função PROC.

Segue o arquivo consertado, agora deve funcionar de acordo.

Exemplo Yure.xlsx (10,7 KB)

2 Curtidas

@Yure
É verdade, peço desculpa e muito obrigado pelo ajuste.
Funcionou perfeitamente!!! Muito obrigado!

1 Curtida

Valeu! Caso precise de mais alguma coisa é só perguntar!

1 Curtida

@xlarruda

Muito obrigado! Funcionou!!

está dando erro ao baixar. eu já tinha essa planilha antes mas acabei apagando e estou precisando novamente.

@Fernando84, Boa Tarde

Conforme o colega @xlarruda, postou a formula, segue a planilha exemplo

Se minha resposta foi útil, clique no coração é uma forma de agradecimento da ajuda

Decio
Modelo Decio.xlsx (10,6,KB)

1 Curtida

@deciog obrigado pela ajuda serve sim mas eu gostaria da planilha “Exemplo Yure.xlxs” do @Yure, porque eu usei a forma como ele fez e dá pra fazer o que eu tenho em mente, Ex: De 0 a 180 dias trazer 22%; De 181 a 360 dias trazer 20%; De 361 a 720 dias trazer 17%.; acima de 721 trazer 15%.

@Fernando84 olá! Infelizmente não tenho mais o modelo, mas acho que você precisa apenas de uma PROCV com correspondência aproximada.

Cria um tópico com sua dúvida e poste um modelo da sua planilha, para que possamos te ajudar melhor com sua dúvida.

@Yure Não consegui enviar a planilha. Deu essa mensagem: “Usuários novos não podem enviar anexo!”

O modelo é esse:
(__ Dias __ ) (Porcentagem)
De_____Até_____%
0______180_____22,5%
181____360_____20,0%
361____720_____17,5%
acima de 721____15,0%

Na planilha as informações ficam assim ai na tabela que tenho quando eu inserir a quantidade de dias quero que automaticamente me diga quantos porcento vai ser descontado.

Testa se é isso que deseja @Fernando84

MODELO FERNANDO.xlsx (8,7,KB)

2 Curtidas

@Yure Ajudou e muito, era isso mesmo é mais simples e dá pra usar em várias outras situações. Valeu pessoal. Obrigado também a @deciog pela disponibilidade. Que Deus abençoe a todos deste grupo e seus respectivos familiares.

Meu caso foi parecido, e me ajudou muito. Gostaria de saber porque tenho que colocar texto?