Função ÍNDICE+CORRESP em tabela filtrada


#1

Olá pessoal, vejam se conseguem me dar uma luz, tenho uma tabela com auto filtros, logo abaixo dela tenho umas tabelas (tipo dinâmicas/mas foram feitas com fórmulas para puxar os campos que eu necessito) que se preenchem de acordo com o intervalo filtrado nestes auto filtros da tabela. Consegui fazer com que uma parte dos valores fossem transportados de acordo com o que necessitava, porém, textos não consegui achar a função, tendo em vista que os valores que são filtrados são únicos no dia da filtragem por data, a fórmula que tá cadastrada puxa na tabela mas no geral, ignorando o filtro. Preciso que a seja buscado o valor de referência na célula B18 ( Loja “Santa Rita-cx1”) e alocado na célula B19 (Operador: “Mario”), fazendo a busca na tabela conforme a data filtrada e o operador do dia. Na planilha botei explicações pra tentar ser mais claro. Muito obrigado desde já.


#2

Bom dia! Já que está usando VBA na sua planilha, inseri uma UDF que poderá te ajudar. Veja:

TESTE NOVO FECHAMENTO SITE.xlsm (57,5 KB)


#3

MARIOLINO
Tente com esta formula também
=ÍNDICE(FECHAMENTOCX[OPERADOR];CORRESP($B$18;B2:B14;0))