Função mínimo e match

Olá a todos!
Preciso de ajuda a resolver um problema em excel. Preciso calcular o valor mínimo de uma coluna de dados, sem filtrar primeiro, com valores negativos em que esse valor não deve ser contemplado. E calcular a data em que ocorre o mínimo, novamente sem contemplar o valor negativo.

Exemplo:
Valores data
1 1/11/2020
2 2/11/2020
3 3/11/2020
4 4/11/2020
-5 5/11/2020

Então o min(A1:A5) = 1, no dia = 1/11/2020
Alguém consegue ajudar?
Obrigada!

Olá bem-vindo.

Veja se esta fórmula ajuda.
Supondo que tenha os valores de “A1:A5” e as datas de “B1:B5”

Coloque a seguinte fórmula em “D1”.

=ÍNDICE($A$1:$B$5;CORRESP(MAIOR($A$1:$A$5;CONT.SE($A$1:$A$5;">0"));$A$1:$A$5;0);2)

Primeiramente obrigada.
Mas dá me o seguinte erro “Function INDEX parameter 3 value 2 is out of range.”

Não sei se faz alguma diferença mas trabalho é no google sheets

Eu testei aqui no meu google sheets e deu certo.

Experimente com a fórmula em inglês.

=INDEX($A$1:$B$5,MATCH(LARGE($A$1:$A$5,COUNTIF($A$1:$A$5,">0")),$A$1:$A$5,0),2)

Já deu! Mas o meu problema, não me expliquei direito, é que tenho uma coluna em que podem aparecer vários valores negativos. Pode conter 1 valor negativo ou vários. A função countif só dá para o segundo mínimo não é? Assim teria que saber qual o meu número de valores mínimos na coluna. Já tentei de tantas formas mas não consigo mesmo…

Esta fórmula devolve a data do menor número da sua lista sempre maior que 0.

Por exemplo caso tenha a lista assim:
1|1/11/2020
2|2/11/2020
1|3/11/2020

Ele vai buscar a data 1/11/2020, mesmo tendo dois 1 na lista pois ele vai buscar o primeiro que aparece.

Mas por exemplo, se tiver então a matriz com dados de temperatura diários na primeira coluna e a correspondente data na segunda:

15,8 1/11/2020
13,6 2/11/2020
-990 3/11/2020
13,6 4/11/2020
14 5/11/2020
13,3 6/11/2020

Ao usar a fórmula =INDEX($A$1:$B$5,MATCH(LARGE($A$1:$A$5,COUNTIF($A$1:$A$5,">0")),$A$1:$A$5,0),2), vai me dar a data 2/11/2020, quando o valor da temperatura mais baixa foi 13,3 no dia 6/11/2020.
Consegue perceber a minha dificuldade?

@Chiva, Bom Dia.

Notei que voce não curtiu a ajuda dada pelo colega

A formula que o colega @AfonsoMira fez, está correta, voce esta limitando a linha até 5,
=INDEX($A$1:$B$5,MATCH(LARGE($A$1:$A$5,COUNTIF($A$1:$A$5,">0")),$A$1:$A$5,0),2)
muda isso para $A$1:$B$30 e $A$1:$A$30 pois o valor 13,3 está na linha 6

Se minha resposta foi útil, clique no coração é uma forma de agradecimento da ajuda

Decio

2 Curtidas