Função Se com soma, ou Procv com soma


#1

Bom dia,
Preciso de uma ajuda, estou com uma planilha de horas extras e tenho uma lista com os dias informando qual funcionário estava de plantão e quantas horas o mesmo realizou. Preciso apontar isso de forma simplificada, ou seja, uma lista com o nome de todos e as horas totais que cada um fez:

Exemplo:

Data Dia da Semana Nome Horario Total de Horas
03/09/2017 Domingo Teste 08:00 as 16:00 8
10/09/2017 Domingo Teste 08:00 as 16:00 8

Teste 16h

Imaginei algo como =SE(C2:C3=“Teste”; SOMA(E2:E3); 0)
Porém ele irá somar todos os campos que eu colocar na soma e preciso somente dos campos desse funcionário.

Alguém pode me dar uma ajuda ou dica?


#2

Olá, @franklinbertanha. Tudo bom?

Você pode usar a função SOMASE que permite somar intervalos que atendem à um critério. por exemplo:

=SOMASE(C2:C3;"Teste";E2:E3)


#3

Xavier

Muito obrigado, havia esquecido desta função. Era exatamente isso que eu precisava.

Obrigado pela ajuda.