Função Soma e Somases na mesma base de cálculo


#1

Bom dia Pessoal,

Estou ajustando umas planilhas e adicionando algumas macros e encontrei algo que me deixou em dúvida no porquê o Excel efetua o cálculo desta forma.

Segue a situação:

Preciso relacionar uma matriz de valores, os quais quero somar, com seus respectivos meses. No caso, estou fazendo Trimestres, então eu somaria X (Janeiro) + Y (Fevereiro) + Z (Março). Inicialmente tentei a seguinte formula :

=SOMASES($B$80:$B$91;$A$80:$A$91;(1;2;3)) - Não deu certo devido os parênteses que representam os Meses (1;2;3), como estamos falando de matrizes, então { }.

Retificando:

=SOMASES($B$80:$B$91;$A$80:$A$91;{1;2;3}) - Também não deu certo

Então por final tentei o seguinte comando:

=SOMA(SOMASES($B$80:$B$91;$A$80:$A$91;{1;2;3})) - Deu certo, porém não entendo a necessidade de colocar a função SOMA, antes do SOMASES.

Alguém consegui me explicar?

Atenciosamente,
Mogisoft


#2

Acredito que seja pq você está fazendo a soma das somas:
Pra exemplificar melhor, seria a mesma coisa de você fazer assim:
=SOMASE($B$80:$B$91;$A$80:$A$91;1) + SOMASE($B$80:$B$91;$A$80:$A$91;2) + SOMASE($B$80:$B$91;$A$80:$A$91;3)

Ou seja são 3 somas dentro de uma, cada uma gera um valor. O “=SOMA” está simplismente somando os resultados dos “SOMASES”.


SOMA 10 em 10 linhas referencia tempo
#3

Faz sentido xlarruda. Obrigado!

Boa!!!