Indicar se é manhã tarde, noite ou madrugada

Boa tarde!
Estou com uma dúvida em uma fórmula, sei que é básica, mas não me recordo como faz.
Preciso indicar em uma planilha se é manhã, tarde, noite ou madrugada, mediante ao horário.

Eu criaria uma tabela extra com as horas de começo e fim de cada turno e usaria um procv na tabela usa do como referência de hora a função agora().

1 Curtida

@Amandacastro, Bom Dia.

Seja bem vinda

Usa desta forma supondo que a hora esteja na célula A1

=SE(A1="";"";SE(A1<=TEMPO(14;0;0);“Manhã”;SE(A1>TEMPO(22;0;0);“Noturno”;“Tarde”)))

NOTA:. As aspa neste fórum é diferente das aspas para uso do Excel quando você fizer
CTRL+C e depois CTRL+V muda todas as aspas para funcionar.

Confere se é desta forma que desejas

Se minha resposta foi útil, clique no coração é uma forma de agradecimento da ajuda

Decio

1 Curtida

Boa tarde!

Agradeço a ajuda, quase deu certo, mas não consegui corrigir.

Com a sua fórmula, ficou assim:

00:00:00 Manhã
01:00:00 Manhã
02:00:00 Manhã
03:00:00 Manhã
04:00:00 Manhã
05:00:00 Manhã
06:00:00 Manhã
07:00:00 Manhã
08:00:00 Manhã
09:00:00 Manhã
10:00:00 Manhã
11:00:00 Manhã
12:00:00 Manhã
13:00:00 Noturno
14:00:00 Noturno
15:00:00 Noturno
16:00:00 Noturno
17:00:00 Noturno
18:00:00 Noturno
19:00:00 Noturno
20:00:00 Noturno
21:00:00 Noturno
22:00:00 Noturno
23:00:00 Noturno

Porém, eu preciso que siga as seguintes regras:

Das 6 às 12 – Manhã

Das 12:01 às 17:59 – Tarde

Das 18:00 às 00:00 – Noite

Das 00:01 às 05:59 – Madrugada

Agradeço a ajuda :blush:

@Amandacastro, Bom Dia.

Para que possamos fazer a formula e testar

Poste um modelo com resultado esperado se não conseguir poste em site como SendSpace / Mega / GoogleDrive / Dropbox Drive outros

ou no meu e-mail [email protected]

Decio

Prezada @Amandacastro Bom dia!

Da mesma forma como sou ajudado neste fórum, também gosto de ajudar, desde que tenha a resposta e, nesse seu caso, julgo tê-la e, portanto, segue abaixo a mesma fórmula enviada pelo @deciog

=SE(A14="";"";SE(A14<=TEMPO(12;0;0);“Manhã”;SE(A14>TEMPO(18;0;0);“Noturno”;“Tarde”)))

Lembrando aquele pequeno detalhe das “aspas”, você terá que fazer igual o que o Décio informou na postagem dele.

Forte abraço,
Sandro

1 Curtida

Prezada @Amandacastro

Através do método de erro e acerto, consegui chegar a um “denominador comum” para a fórmula em questão. É só copiar e colar a nova fórmula, praticamente idêntica à anterior, enviada pelo @deciog, mas algumas pequenas mas pertinentes modificações.

=SE(A14="";"";SE(A14<=TEMPO(11;59;59);“Manhã”;SE(A14>TEMPO(17;59;59);“Noite”;“Tarde”)))

Abraços,
Sandro

1 Curtida