Lista de palavras-chave


#1

Olá pessoal! espero que vcs possam me ajudar.
Tenho uma planilha com uma lista de empresas ordenadas pela razao social.
E tenho tb uma lista de palavras-chave que nao podem aparecer nas razoes sociais das empresas.
Se alguma das palavras-chave da lista aparecer na razao social da empresa, essa empresa deve ser excluida da seleção.

Já quebrei a cabeça e busquei de tudo na internet e nda.
Alguém me dá uma luz? :slight_smile:
grata


#2

Bom dia @chiara. Não consegui resolver seu problema, mas a seguinte fórmula pode dar alguma ideia para os outros usuários te ajudarem:

=SEERRO(ÍNDICE($A$1:$A$6;AGREGAR(15;6;LIN($A$1:$A$6)/($A$1:$A$6<>$D$1:$D$6);LINS($A$1:A1)));"")

Sendo a primeira matriz ($A$1:$A$6) as razões sociais;
Sendo a segunda matriz ($D$1:$D$6) com as palavras-chave proibidas.

O problema que encontrei foi que as posições em que estão as palavras-chave fazem diferença (o que não queremos) e não sei como fazer para implementar caracteres-curinga na fórmula para encontrar nas razões sociais. Se alguém conseguir resolver esses problemas na fórmula funcionará bacana.


#3

Chiara, Bom Dia.

Eu usaria desta forma para mostrar nomes aceitos,

Na celula A os nomes e na celula C palavra não aceitas

*=SE(É.NÃO.DISP(ÍNDICE($C$2:$C$6;PROC(10^308;CORRESP(ARRUMAR(EXT.TEXTO(SUBSTITUIR(A2;" “;REPT(” ";255));{1;2;3;4;5}255-254;255));$C$2:$C$6;0));1));“Aceito”;“ERRO”)

Se minha resposta foi útil, clique no coração é uma forma de agradecimento da ajuda

Decio


#4

Boa tarde @chiara,

Uma duvida, você quer excluir da seleção ou excluir definitivamente da sua sua planilha ?

Aguardo a sua resposta.
abs


#5

oLÁ Obrigada! Porém diz que inseri argumentos demais. :frowning:


#6

não, so indicar que devo excluir, so indicar a ação, ou que contém alguma das palavras que nao devem estar na coluna.


#7

chiara

Olha o modelo

Se minha resposta foi útil, clique no coração é uma forma de agradecimento da ajuda

Decio
Modelo Decio.xlsx (9,6 KB)


#8

deu super certo!! vc eh fera! tks!!!


#10

Chiara, Bom Dia.

Pode mandar por meu e-mail deciog@gmail.com que farei a formula correta

Decio