Localizar numero entre duas colunas


#1

Boa tarde!

Tenho uma planilha onde uma coluna A “Nota Fiscal” NF e na coluna B e C tem o Valor “MINIMO” e “MAXIMO” EX: NF A de 1 a 10, NF B de 11 a 20, NF C de 21 a 30… e tenho uma coluna com números aleatórios 7, 21, 34, 12, 46, 16, 24, 19.

tenho utilizado as formulas para identificar quais dos números da coluna G estão dentro das NF utilizando as formulas abaixo, porem se o numero não faz parte de nenhuma NF ele atrela a mais proxima, saberiam me ajudar para que não mostre nada quando não encontrar?

OBS: essa planilha pode ter mais de 10 mil linhas.excel%202


#2

formulas que ja utilizei:

=ÍNDICE($A$2:$A$1000;CORRESP(F2;$B$2:$B$1000;1))

=PROCV(F2,$B$1:$D$6,3,1)