Localizar valor entre dois valores


#1

Bom dia!

Tenho uma planilha onde uma coluna A “Nota Fiscal” contem as NF A, B, C, D, E. e na coluna B e C tem o Valor “MINIMO” e “MAXIMO” EX: NF A de 1 a 10, NF B de 11 a 20, NF C de 21 a 30… e tenho uma coluna com números aleatórios 7, 9, 20, 31, 41, 16, 24, 19.

Gostaria de saber uma formula que me mostre qual a Nota Fiscal desses números aleatórios uma vez que pra localizar eles terei que saber se ele estão entre o valor MINIMO E MAXIMO.

EXCEL


#2

Cole em G2 e finalize com Ctrl + Shift + Enter:

=ÍNDICE($A$2:$A$6;CORRESP(PROCV(F2;$B$2:$B$6;1;1);$B$2:$B$6;0))


#3

Deu certo apliquei na minha planilha obrigado


#4

dugsblack, boa tarde!

Assim também funciona.
cole em G2 e Arraste

=SE(E(F2>=$B$2;F2<=$C$2);$A$2;SE(E(F2>=$B$3;F2<=$C$3);$A$3;SE(E(F2>=$B$4;F2<=$C$4);$A$4;SE(E(F2>=$B$5;F2<=$C$5);$A$5;SE(E(F2>=$B$6;F2<=$C$6);$A$6;"")))))


#5

Esta é a que melhor atendeu entretanto se eu tiver que lidar com mais de 10 mil linhas se torna inviavel utilizar esta formula pelo tamanho que fica para configurar