Macro apagar e voltar ao inicio

Olá pessoal
Precisava de criar uma macro que apagasse o conteúdo de 2 colunas e que voltasse a inserir a condição original.

image

A macro precisa apagar o nº 8 e o nº 17, e repor a formula original que é =SE(A11="";"";"-")

Obrigado

Boa tarde.
Poste as colunas e as linhas que necessita fazer isto, mas de um modo geral, será mais ou menos isto:

Sub xxx()
' supondo saida na coluna C e D e linha da 11 a 16

    Plan1.Cells(11, 3).FormulaLocal = "=se(A11=" & """""" & ";" & """""" & ";" & """" & "-" & """" & ")"
    Plan1.Cells(12, 3).FormulaLocal = "=se(A12=" & """""" & ";" & """""" & ";" & """" & "-" & """" & ")"
    Plan1.Cells(13, 3).FormulaLocal = "=se(A13=" & """""" & ";" & """""" & ";" & """" & "-" & """" & ")"
    Plan1.Cells(14, 3).FormulaLocal = "=se(A14=" & """""" & ";" & """""" & ";" & """" & "-" & """" & ")"
    Plan1.Cells(15, 3).FormulaLocal = "=se(A15=" & """""" & ";" & """""" & ";" & """" & "-" & """" & ")"
    Plan1.Cells(16, 3).FormulaLocal = "=se(A16=" & """""" & ";" & """""" & ";" & """" & "-" & """" & ")"

    Plan1.Cells(11, 4).FormulaLocal = "=se(A11=" & """""" & ";" & """""" & ";" & """" & "-" & """" & ")"
    Plan1.Cells(12, 4).FormulaLocal = "=se(A12=" & """""" & ";" & """""" & ";" & """" & "-" & """" & ")"
    Plan1.Cells(13, 4).FormulaLocal = "=se(A13=" & """""" & ";" & """""" & ";" & """" & "-" & """" & ")"
    Plan1.Cells(14, 4).FormulaLocal = "=se(A14=" & """""" & ";" & """""" & ";" & """" & "-" & """" & ")"
    Plan1.Cells(15, 4).FormulaLocal = "=se(A15=" & """""" & ";" & """""" & ";" & """" & "-" & """" & ")"
    Plan1.Cells(16, 4).FormulaLocal = "=se(A16=" & """""" & ";" & """""" & ";" & """" & "-" & """" & ")"

End Sub

Não é o modo mais simples, mas sem saber as linhas e colunas que vc vai usar… assim é mais facil de vc entender.

abs