Macro para adicionar linhas e copiar fórmulas junto com Condicional


#1

Boa Tarde Pessoal, preciso muito de sua ajuda.
Criei uma planilha com algumas condicionais, mas não consegui criar a macro.
Também estou com problemas com as condicionais que as vezem funcionam e outras vezes não.

As regras e as macros seriam as seguintes:

NA CÉLULA I6:

        1.SE  DATA DO DIA (Y2) - DATA DO EVENTO (A6) = 6  -> RETORNAR  cor laranja NA CELULA I6						
         2.SE DATA DO DIA (Y2) - DATA DO EVENTO (A6) > 6 -> RETORNAR COR VERMELHO COM FRASE "INSERIR N. TRA"						
					
         3.SE I6 FOR INSERIDO NUMERO DE TRA (se inserir qualquer valor ou letra), RETORNAR A COR ORIGINAL												

4.NA CÉLULA T6, INSERIR CONDIÇÃO “=SE(SOMA($Y$2-A6)>6;“YES”;“NO””

  1. AGORA FINALIZANDO AS CONDIÇÕES: CRIAR UMA MACRO PARA QUE EU ADICIONE UMA LINHA SEGUIDA DA ÚLTIMA LINHA DO DOCUMENTO QUE CONTEMPLE TODAS AS FÓRMULAS E CONDIÇÕES NAS LINHAS SEGUINTES.
  2. CRIAR UMA MACRO PARA QUE AS LINHAS QUE FORAM ADICIONADAS NO MESMO DIA FIQUEM EM AMARELO E QUE DEIXEM DE FICAR AMARELO NO DIA SEGUINTE.
  3. O BOTAO DA MACRO DEVE FICAR OCULTO NA IMPRESSÃO
  4. AS CÉLULAS COM FÓRMuLAS E CONDIÇÕES DEVEM FICAR BLOQUEADAS PARA EDIÇÃO

Se puder ser feito tudo via MACRO seria melhor.

Desde já, agradeço a ajuda.

Igor


#2

É algo trabalhoso. Mais tarde vejo se consigo fazer.


#3

@igorifv, como o amigo no post anterior disse é algo trabalhoso de fazer.

Caso precise de uma ajuda profissional entre em contato que podemos fazer um orçamento sem compromisso!