MUDAR VALOR EM UMA CÉLULA QUANDO COLOCAR UM VALOR EM OUTRA CÉLULA


#1

Minha dúvida é a seguinte:

A1=10 B1=0 C1=0 D1=0

Preciso de uma fórmula para que quando eu digitar um valor em B1, então A1 assuma esse valor. E consequentemente, se eu digitar agora um valor em C1, então A1 assume agora o valor de C1, ok?

Digamos que eu digito o número 20 na célula B1, então A1 agora muda de 10 para 20. E se eu digitar 30 em C1, então A1 muda para 30. A mesma coisa se eu digitar agora em D1, então A1 assue esse valor.

Lembrando que somente A1 é que altera conforme a célula seguinte é preenchida. Se D1 for 0, então A1 assume C1, mas se D1<>0, então anula-se B1 e agora A1 assume C1.

Espero que tenha me expressado de forma compreensiva!


#2

Veja se ajuda:

Insira essa formula em A1

=SE(SE(E(B1<>0;C1<>0;D1<>0);D1;SE(E(B1<>0;C1<>0);C1;SE(B1<>0;B1)))=FALSO;0;SE(E(B1<>0;C1<>0;D1<>0);D1;SE(E(B1<>0;C1<>0);C1;SE(B1<>0;B1))))


#3

xlarruda,

Muito obrigado pela sua atenção e contribuição! Ajudou demais e realmente a fórmula é essa sim. Precisei apenas fazer uma correção e acréscimos.

A correção é que eu queria que A1 já comece com um valor e no caso da sua fórmula, A1 começa com “0”. Então substitui o “0” depois de falso pela célula que continha o valor que eu queria que fosse inserido em A1. Legal…

O que eu acrescentei foram mais 8 parâmetros porque na verdade minha planilha vai contar 12 células, ou seja A1,B1,C1,D1,E1,F1,G1,H1,I1,J1,K1,L1. Entendeu?

Então a Fórmula final ficou assim:

=SE(SE(E(L56<>0;L57<>0;L58<>0;L59<>0;L60<>0;L61<>0;L62<>0;L63<>0;L64<>0;L65<>0;L66<>0);L66;SE(E(L56<>0;L57<>0;L58<>0;L59<>0;L60<>0;L61<>0;L62<>0;L63<>0;L64<>0;L65<>0);L65;SE(E(L56<>0;L57<>0;L58<>0;L59<>0;L60<>0;L61<>0;L62<>0;L63<>0;L64<>0);L64;SE(E(L56<>0;L57<>0;L58<>0;L59<>0;L60<>0;L61<>0;L62<>0;L63<>0);L63;SE(E(L56<>0;L57<>0;L58<>0;L59<>0;L60<>0;L61<>0;L62<>0);L62;SE(E(L56<>0;L57<>0;L58<>0;L59<>0;L60<>0;L61<>0);L61;SE(E(L56<>0;L57<>0;L58<>0;L59<>0;L60<>0);L60;SE(E(L56<>0;L57<>0;L58<>0;L59<>0);L59;SE(E(L56<>0;L57<>0;L58<>0);L58;SE(E(L56<>0;L57<>0);L57;SE(L56<>0;L56)))))))))))=FALSO;N55;SE(E(L56<>0;L57<>0;L58<>0;L59<>0;L60<>0;L61<>0;L62<>0;L63<>0;L64<>0;L65<>0;L66<>0);L66;SE(E(L56<>0;L57<>0;L58<>0;L59<>0;L60<>0;L61<>0;L62<>0;L63<>0;L64<>0;L65<>0);L65;SE(E(L56<>0;L57<>0;L58<>0;L59<>0;L60<>0;L61<>0;L62<>0;L63<>0;L64<>0);L64;SE(E(L56<>0;L57<>0;L58<>0;L59<>0;L60<>0;L61<>0;L62<>0;L63<>0);L63;SE(E(L56<>0;L57<>0;L58<>0;L59<>0;L60<>0;L61<>0;L62<>0);L62;SE(E(L56<>0;L57<>0;L58<>0;L59<>0;L60<>0;L61<>0);L61;SE(E(L56<>0;L57<>0;L58<>0;L59<>0;L60<>0);L60;SE(E(L56<>0;L57<>0;L58<>0;L59<>0);L59;SE(E(L56<>0;L57<>0;L58<>0);L58;SE(E(L56<>0;L57<>0);L57;SE(L56<>0;L56))))))))))))

Muito obrigado mesmo!


#4

Bom dia, acho que desta forma abaixo seria mais simples…
Faça um teste e verifique se é isto mesmo que vc quer…
abs

=SE(L56<>0;SE(L57<>0;SE(L58<>0;SE(L59<>0;SE(L60<>0;SE(L61<>0;SE(L62<>0;SE(L63<>0;SE(L64<>0;SE(L65<>0;SE(L66<>0;L66;L65);L64);L63);L62);L61);L60);L59);L58);L57);L56);N55)