Não consigo encontrar o erro neste código


#1

Muito bom dia a todos,
estou a tentar encontrar uma solução para este código, mais não consigo encontrar o erro.
=SE(A3="";"";SE(B3=HOJE();“VENCER HOJE”;SE(B3<HOJE();“ATRASADO”;B3-HOJE()&“dias para vencer”)))

Quando eu utilizo o código no open office, ele resulta na perfeição, mais quando tento no google sheets, ele me dá erro constantemente. E lá, eu não consigo colocar o ; . Pois ele insiste somente na vírgula.

Mais uma vez agradeço a quem puder ajudar.


#2

@Filipe

O Google Sheets trabalha com formula em ingles tenta desta forma

=IF(A3="","",IF(B3=TODAY(),“VENCER HOJE”,IF(B3<TODAY(),“ATRASADO”,B3-TODAY()&“dias para vencer”)))

Se minha resposta foi útil, clique no coração é uma forma de agradecimento da ajuda

Decio


#3

muito obrigado, irei tentar.
Mesmo que não dê, irei clicar no coração.
O que conta é a boa vontade.


#4

Não sei porque ele não me aceita o ;


#5

@Filipe

Eu coloquei a formula dentro da planilha a inglesa esta com um espaço antes para que você possa ver, copia ela e tira o espaço antes coloca na planilha, porque, quando é copiado a formula neste fórum em forma de texto ela coloca as aspas de forma diferente, tem também em português copia e teste ok

Se minha resposta foi útil, clique no coração é uma forma de agradecimento da ajuda

Decio
Exemplo Decio.xlsx (9,7 KB)